Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1512959

Summary: Upgrade from 6.2 -> 6.3 failed due to dependency issue in case python-pulp-agent-lib package installed on satellite
Product: Red Hat Satellite 6 Reporter: Sachin Ghai <sghai>
Component: Foreman MaintainAssignee: Anurag Patel <apatel>
Status: CLOSED ERRATA QA Contact: Evgeni Golov <egolov>
Severity: high Docs Contact:
Priority: high    
Version: 6.3.0CC: adahms, ahumbe, apatel, bbuckingham, bkearney, egolov, ehelms, gpayelka, inecas, kgaikwad, lzap, mbacovsk, pmoravec, sabnave, swadeley
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
Customers who manually upgrade from Satellite 6.2 to Satellite 6.3 must enable the satellite-tools repository to successfully perform the upgrade if they already have installed the python-pulp-agent-lib package. This package from Satellite 6.2 was moved into the tools repository for Satellite 6.3.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-19 17:23:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1122832, 1496794    

Description Sachin Ghai 2017-11-14 14:03:38 UTC
Description of problem:
satellite upgrade from 6.2 -> 6.3 failed due to below dependency issue. Issue is that python-pulp-agent-lib package comes w/ satellite6.2 repo and with 6.3 its moved to tools repo.

The reason, I think, the package was installed on satellite because I guess someone installed pulp-admin-client along w/ pulp-rpm-admin-extensions or pulp-rpm-handlers.

pulp-rpm-handlers is dependent on python-pulp-agent-lib




 Failed with dependencies 
 I have started in screen... so you can check 
 --> Finished Dependency Resolution
 Error: Package: python-pulp-agent-lib-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
            Requires: python-pulp-common = 2.8.7.15
            Removing: python-pulp-common-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                python-pulp-common = 2.8.7.15-1.el7sat
            Updated By: python-pulp-common-2.13.4.2-1.el7sat.noarch (Satellite-6.3.0-RHEL-7-20171107.1)
                python-pulp-common = 2.13.4.2-1.el7sat
 **********************************************************************
 yum can be configured to try to resolve such errors by temporarily enabling
 disabled repos and searching for missing dependencies.
 To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
 **********************************************************************
 --> Running transaction check
 ---> Package kernel.x86_64 0:3.10.0-514.21.1.el7 will be erased
 ---> Package python-pulp-common.noarch 0:2.8.7.15-1.el7sat will be updated
 --> Processing Dependency: python-pulp-common = 2.8.7.15 for package: python-pulp-agent-lib-2.8.7.15-1.el7sat.noarch
 --> Finished Dependency Resolution
 Error: Package: python-pulp-agent-lib-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
            Requires: python-pulp-common = 2.8.7.15
            Removing: python-pulp-common-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                python-pulp-common = 2.8.7.15-1.el7sat
            Updated By: python-pulp-common-2.13.4.2-1.el7sat.noarch (Satellite-6.3.0-RHEL-7-20171107.1)
                python-pulp-common = 2.13.4.2-1.el7sat
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install python-pulp-agent-lib on 6.2
2. perform upgrade w/ 6.3
3.

Actual results:
dependency issue as reported above

Expected results:


Additional info:

Comment 2 Sachin Ghai 2017-11-14 14:05:27 UTC
Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                              Arch                                  Version                                          Repository                                                       Size
===================================================================================================================================================================================================================
Installing:
 pulp-rpm-handlers                                    noarch                                2.8.7.18-1.el7sat                                rhel-7-server-satellite-6.2-rpms                                 77 k
Installing for dependencies:
 python-pulp-agent-lib                                noarch                                2.8.7.15-1.el7sat                                rhel-7-server-satellite-6.2-rpms                                 95 k

Transaction Summary
===================================================================================================================================================================================================================

Comment 6 Ivan Necas 2017-11-14 19:16:59 UTC
Eric: how do you suggest to proceed with this one?

Comment 8 Eric Helms 2017-11-28 19:05:31 UTC
For 6.3, users will need to enable the tools repository if they were using katello-agent on their 6.2 installation in order to get the client bits.

Comment 9 Ivan Necas 2017-11-28 19:22:25 UTC
I wonder if we could help with foreman-maintain here, when enabling repos?

Comment 13 Ivan Necas 2018-01-02 17:00:22 UTC
*** Bug 1516380 has been marked as a duplicate of this bug. ***

Comment 15 Swapnil Abnave 2018-01-04 12:19:52 UTC
Created redmine issue http://projects.theforeman.org/issues/22151 from this bug

Comment 16 pm-sat@redhat.com 2018-01-08 11:19:40 UTC
Upstream bug assigned to apatel@redhat.com

Comment 17 pm-sat@redhat.com 2018-01-09 15:19:58 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/22151 has been resolved.

Comment 19 Evgeni Golov 2018-02-02 15:33:55 UTC
VERIFIED
rubygem-foreman_maintain-0.1.3-1.el7sat.noarch

# subscription-manager repos --list-enabled
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-server-rhscl-7-rpms
Repo Name: Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/rhscl/1/os
Enabled:   1

Repo ID:   rhel-7-server-satellite-maintenance-6-rpms
Repo Name: Red Hat Satellite Maintenance 6 (for RHEL 7 Server) (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/7Server/$basearch/sat-maintenance/6/os
Enabled:   1

Repo ID:   rhel-7-server-rpms
Repo Name: Red Hat Enterprise Linux 7 Server (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/$releasever/$basearch/os
Enabled:   1

Repo ID:   rhel-7-server-satellite-6.2-rpms
Repo Name: Red Hat Satellite 6.2 (for RHEL 7 Server) (RPMs)
Repo URL:  https://cdn.redhat.com/content/dist/rhel/server/7/7Server/$basearch/satellite/6.2/os
Enabled:   1

# rpm -q pulp-admin-client pulp-rpm-admin-extensions
pulp-admin-client-2.8.7.18-1.el7sat.noarch
pulp-rpm-admin-extensions-2.8.7.18-1.el7sat.noarch

# foreman-maintain upgrade list-versions
6.2.z
6.3

# foreman-maintain upgrade run --target-version 6.3
...
Running Migration scripts to Satellite 6.3
================================================================================
Setup repositories: 
- Configuring repositories for 6.3                                    [FAIL]    
Failed executing subscription-manager repos --enable=rhel-7-server-rpms --enable=rhel-server-rhscl-7-rpms --enable=rhel-7-server-satellite-maintenance-6-rpms --enable=rhel-7-server-satellite-tools-6.3-rpms --enable=rhel-7-server-satellite-6.3-rpms, exit status 1:
 Error: 'rhel-7-server-satellite-tools-6.3-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories.
Error: 'rhel-7-server-satellite-6.3-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories.
Repository 'rhel-7-server-rpms' is enabled for this system.
Repository 'rhel-7-server-satellite-maintenance-6-rpms' is enabled for this system.
Repository 'rhel-server-rhscl-7-rpms' is enabled for this system.
--------------------------------------------------------------------------------
Scenario [Migration scripts to Satellite 6.3] failed.

But at least it tries to enable the right repos!

And indeed, enabling the right beta repos by hand and the upgrade ends up fine:


# subscription-manager repos --enable=rhel-7-server-rpms --enable=rhel-server-rhscl-7-rpms --enable=rhel-7-server-satellite-maintenance-6-rpms --enable=rhel-7-server-satellite-tools-6-beta-rpms --enable=rhel-server-7-satellite-6-beta-rpms
Repository 'rhel-7-server-rpms' is enabled for this system.
Repository 'rhel-7-server-satellite-maintenance-6-rpms' is enabled for this system.
Repository 'rhel-server-7-satellite-6-beta-rpms' is enabled for this system.
Repository 'rhel-7-server-satellite-tools-6-beta-rpms' is enabled for this system.
Repository 'rhel-server-rhscl-7-rpms' is enabled for this system.

# foreman-maintain upgrade run --target-version 6.3 --whitelist="repositories-setup"

# rpm -q pulp-admin-client pulp-rpm-admin-extensions
pulp-admin-client-2.13.4.2-1.el7sat.noarch
pulp-rpm-admin-extensions-2.13.4.2-2.el7sat.noarch

Comment 26 Evgeni Golov 2018-02-19 07:43:47 UTC
BK, I was talking about the doc text of this bug, which currently reads:
Customers who upgrade from Satellite 6.2 to Satellite 6.3 must enable the satellite-tools repository to successfully perform the upgrade if they already have installed the python-pulp-agent-lib package. This package from Satellite 6.2 was moved into the tools repository, and will be moved back to the main Satellite 6 repository ahead of the general availability of Satellite 6.3.

Does Stephens text replace it? Sounds fine to me then.
My impression was that errata texts and doc texts in BZs are different things (and are used for different purposes).

Comment 30 errata-xmlrpc 2018-02-19 17:23:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0330