Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1512927

Summary: Hardwired haproxy.cfg defaults_options
Product: Red Hat OpenStack Reporter: Robin Cernin <rcernin>
Component: puppet-tripleoAssignee: Michele Baldessari <michele>
Status: CLOSED ERRATA QA Contact: Udi Shkalim <ushkalim>
Severity: medium Docs Contact:
Priority: medium    
Version: 11.0 (Ocata)CC: aschultz, augol, bperkins, jjoyce, jschluet, jstransk, michele, mkrcmari, rscarazz, slinaber, sputhenp, tvignaud, vcojot
Target Milestone: betaKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-tripleo-8.3.1-0.20180304033908.ed3285e.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:39:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Robin Cernin 2017-11-14 13:00:34 UTC
Description of problem:

We are having hardwired haproxy.cfg defaults_options:

https://github.com/openstack/puppet-tripleo/blob/master/manifests/haproxy.pp#L828-L834

We are looking for configuring the tune.ssl.default-dh-param 4096 as additional parameter to defaults_options yet we have not found a way to do it except using sed in post-configuration script.

We probably need something like in global_options https://github.com/openstack/puppet-tripleo/blob/master/manifests/haproxy.pp#L827

Version-Release number of selected component (if applicable):

Ocata

Comment 4 errata-xmlrpc 2018-06-27 13:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086