Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1512459

Summary: virtio-keyboard-pci missing some keys
Product: Red Hat Enterprise Linux 7 Reporter: Guo, Zhiyi <zhguo>
Component: qemu-kvm-rhevAssignee: Gerd Hoffmann <kraxel>
Status: CLOSED ERRATA QA Contact: Guo, Zhiyi <zhguo>
Severity: low Docs Contact:
Priority: low    
Version: 7.5CC: chayang, jinzhao, juzhang, knoel, michen, mrezanin, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: All   
Whiteboard:
Fixed In Version: qemu-kvm-rhev-2.12.0-1.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-01 11:01:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Guo, Zhiyi 2017-11-13 09:48:56 UTC
Description of problem:
Media keys are missing for qemu virtio-keyboard-pci

Version-Release number of selected component (if applicable):
host & guest: 3.10.0-781.el7.x86_64
qemu-kvm-rhev-2.10.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot a rhel7.5 guest with virtio-keyboard-pci:
/usr/libexec/qemu-kvm -name input-test -m 2G \
-cpu qemu64,check \
-smp 2 \
-device cirrus-vga \
-netdev tap,id=idinWyYp,vhost=on -device virtio-net-pci,mac=42:ce:a9:d2:4d:d7,id=idlbq7eA,netdev=idinWyYp \
-uuid 215e11b2-a869-41b5-91cd-6a32a907be7e \
-device ich9-usb-uhci6 \
-drive file=/home/rhel75.qcow2,if=none,id=drive-scsi-disk0,format=qcow2,cache=none,werror=stop,rerror=stop  -device ide-drive,drive=drive-scsi-disk0 \
-qmp unix:/tmp/input-port,server,nowait \
-monitor stdio \
-device virtio-keyboard-pci \
2.Inside guest, open gnome-terminal,execute 'showkey -k | grep press' and try to input media keys, keys I used are:
'NEXTSONG',
'PREVIOUSSONG',
'STOPCD',
'PLAYPAUSE',
'MUTE',
'VOLUMEUP',
'VOLUMEDOWN',
'MAIL',
'CALC',
'COMPUTER',
'SEARCH',
'HOMEPAGE',
'BACK',
'FORWARD',
'STOP',
'REFRESH',
'FAVORITES'
3.After input finish, wait for 10s for showkey to terminate and check the output of showkey

Actual results:
No output from showkey

Expected results:
the keycode of media keys output here:
keycode 163 press
keycode 165 press
keycode 166 press
keycode 164 press
keycode 113 press
keycode 115 press
keycode 114 press
keycode 155 press
keycode 140 press
keycode 157 press
keycode 217 press
keycode 172 press
keycode 158 press
keycode 159 press
keycode 128 press
keycode 173 press

Additional info:
ps2-kbd has all these keys. vnc/spice won't affect the result.

Comment 2 Guo, Zhiyi 2017-11-14 02:07:21 UTC
Summary the missing keys are:
'NEXTSONG',
'PREVIOUSSONG',
'STOPCD',
'PLAYPAUSE',
'MUTE',
'VOLUMEUP',
'VOLUMEDOWN',
'MAIL',
'CALC',
'COMPUTER',
'SEARCH',
'HOMEPAGE',
'BACK',
'FORWARD',
'STOP',
'REFRESH',
'FAVORITES',
'KATAKANA',
'HIRAGANA',
'HENKAN'

Comment 3 Gerd Hoffmann 2018-04-19 13:00:44 UTC
Upstream commit ae6b06ab655b21c19b234ce3422f694d11a013e0 (in 2.12) should fix that.

Comment 4 Ademar Reis 2018-04-20 21:59:40 UTC
(In reply to Gerd Hoffmann from comment #3)
> Upstream commit ae6b06ab655b21c19b234ce3422f694d11a013e0 (in 2.12) should
> fix that.

Then moving to POST + fixed-in-version to wait for the rebase.

Comment 8 errata-xmlrpc 2018-11-01 11:01:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443