Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1512253

Summary: Most buttons not detected on Bamboo Ink Stylus
Product: [Fedora] Fedora Reporter: gabe
Component: bluezAssignee: Don Zickus <dzickus>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 26CC: bnocera, dwmw2, dzickus, extras-orphan, gabe, peter.hutterer, spacewar
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-13 00:51:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description gabe 2017-11-12 02:59:37 UTC
Description of problem:

When using the Bamboo Ink Bluetooth stylus, two of the three buttons are not registered. (https://www.bestbuy.com/site/wacom-bamboo-ink-smart-stylus-black/5731102.p?skuId=5731102)

xinput does not see the buttons. xsetwacom does not see it as a stylus at all.

Version-Release number of selected component (if applicable):

* xsetwacom version 0.34.2
* xinput version 1.6.2
* XI version 2.3
* bluetoothctl version 5.46
* uname -a >>> Linux Gappleto-Inspiron 4.13.11-200.fc26.x86_64 #1 SMP Thu Nov 2 18:28:35 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Consistently

Steps to Reproduce:
1. Pair/connect the stylus
2. Bring close to screen
3. Press button nearest stylus tip, notice that it does something
4. Press button closer to the middle, notice that it does nothing, and is not detected by xinput
5. Press button at "eraser end", notice that it does nothing, and is not detected by xinput

Actual results:

These buttons are not detected by any component I know to test

Expected results:

These buttons should be detected

Additional info:

I am running Fedora 26 KDE if that affects anything

Comment 1 gabe 2017-11-12 21:20:44 UTC
Also, it does not show up at all under wireshark, though my other bluetooth devices do.

Comment 2 Peter Hutterer 2017-11-13 00:51:36 UTC
fwiw linuxwacom doesn't exist anymore as component, it got orphaned in the fedora 10 or so time frame.

regarding the bug: none of the bluetooth pens are supported, we don't have the specs for them and Wacom doesn't provide linux support for them. You could try reverse-engineering the protocol and adding it to bluez but other than that you're out of luck for now, sorry.

Comment 3 gabe 2017-11-13 02:58:57 UTC
Fair enough. It's not like this bug is mission critical, just mildly limiting.

I didn't really know what component to apply this to, since it seemed to touch several.

Do you have any recommendations as to what I could use to reverse engineer it, since it's not showing up in wireshark?

Comment 4 Peter Hutterer 2017-11-14 01:44:34 UTC
for the bamboo spark, I had some success with recording the bluetooth interaction on an android tablet (where the tablet works) and then analysing the recorded dumps with wireshark. Didn't get anywhere (yet) but it's one approach to get started.