Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511982

Summary: MariaDB crashing due to specific SQL statement
Product: Red Hat Enterprise Linux 7 Reporter: SHAURYA <sshaurya>
Component: mariadbAssignee: Michal Schorm <mschorm>
Status: CLOSED CURRENTRELEASE QA Contact: qe-baseos-daemons
Severity: high Docs Contact:
Priority: high    
Version: 7.4CC: abhavsar, briang, databases-maint, hhorak, mmuzila, redhat-bugzilla, robert.scheck, sshaurya, toneata, vdanek
Target Milestone: rcKeywords: FastFix, ZStream
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1584024 (view as bug list) Environment:
Last Closed: 2018-10-30 15:43:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1549615, 1551022, 1584024    

Description SHAURYA 2017-11-10 14:57:09 UTC
Created attachment 1350547 [details]
Maridb Log files and stack trace

Description of problem:

From our point of view, MariaDB as shipped with RHEL 7.4 can be crashed using a specific SQL statement, which we treat as a bug in MariaDB.

Version-Release number of selected component (if applicable):

mariadb-5.5.56-2.el7.x86_64.rpm 

How reproducible:

Always

Steps to Reproduce:

The SQL statement is part of the attachment var-log-mariadb-mariadb.log.xz.

We do not have an exact command-line-only reproducer, given the statement is created and run by a web application. However the attached MariaDB log file provides the statement and a stack trace.


Actual results:

mariadb crashes

Expected results:

Mariadb should not crash

Additional info:

Comment 7 Michal Schorm 2017-11-22 15:58:32 UTC
I'm still struggling to get the minimal reproducer, due to quite big amount of tables connected together by foreign keys.

However, This issue has been resolved by upstream in 5.5.57 version.

Comment 9 Robert Scheck 2017-12-13 00:04:58 UTC
May I kindly request that attachment 1350547 [details] gets marked private?
I provided this log file to GSS on request, while the log file contains
information which are definitely not meant to get public. Aside of this,
I delivered a "minimal" reproducer also to GSS already some time ago - 
not sure if it made to this bug report (privately).

Finally...will RHEL 7.5 ship MariaDB 5.5.57? I am not seeing release
engineering flags here.

Comment 10 Honza Horak 2017-12-13 14:03:45 UTC
(In reply to Robert Scheck from comment #9)
> Finally...will RHEL 7.5 ship MariaDB 5.5.57? I am not seeing release
> engineering flags here.

At this point there are not many other issues in mariadb package that would make us plan mariadb updating it any time soon, so if this issue is important for you, please, make sure the business justification is properly tracked in the customer portal.

Comment 11 Robert Scheck 2017-12-13 17:04:39 UTC
Honza, can you please mark attachment 1350547 [details] as private?

Comment 14 Robert Scheck 2018-01-10 13:08:39 UTC
Using mariadb-server-5.5.58-1.el7_4.test_build_rhbz1511982.x86_64, there is
at least no crash so far, my colleagues did not yet verify the bigger aspects
of the software using MariaDB, but no crash is good from admin perspective :)

I would provide a complete feedback once I get it from my colleagues, but how
is the chance to get this into a regular RHEL update soon, like 7.5?

Comment 15 Robert Scheck 2018-01-10 13:49:43 UTC
Status update from my colleagues: Everything works as expected, so we are
really interested in getting this as a regular update rather unsupported :)

Comment 17 Michal Schorm 2018-01-11 13:41:57 UTC
I'm happy to hear it solved your issues :)

The best I can say about "when it will be released as a regular update" is the same as Honza said in comment 10. I don't know any date nor can set any.

Comment 18 Robert Scheck 2018-01-11 17:15:14 UTC
I already provided a business justification to GSS, but not much outcome
regards release management/engineering.