Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511823

Summary: [RFE] Automatically synchronize networks of cluster with default network provider
Product: [oVirt] ovirt-engine Reporter: Dominik Holler <dholler>
Component: Backend.CoreAssignee: Dominik Holler <dholler>
Status: CLOSED CURRENTRELEASE QA Contact: Michael Burman <mburman>
Severity: high Docs Contact:
Priority: high    
Version: 4.2.0CC: alkaplan, apinnick, bugs, danken, dholler, mburman, mkalfon, myakove, ylavi
Target Milestone: ovirt-4.2.4Keywords: FutureFeature
Target Release: ---Flags: rule-engine: ovirt-4.2+
mburman: testing_plan_complete+
ylavi: planning_ack+
danken: devel_ack+
mavital: testing_ack+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
When you add an external network provider, a check box allows you to automatically synchronize your cluster networks with the networks imported from the default network provider. The networks are immediately available for the virtual machines.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-26 08:38:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Network RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1539765, 1543062, 1568413    
Bug Blocks: 1548815    
Attachments:
Description Flags
Example to enable auto-synv on the REST-API via the oVirt python sdk none

Description Dominik Holler 2017-11-10 08:52:11 UTC
Add a boolean property to external network providers, which enables the automatic synchronization with all clusters that have that external provider as the default provider.

On import of a new network from the provider,
 - the networks of the external provider will be imported to every data center
   in the set of datacenters of the clusters that have that external provider
   as the default provider,
 - a vNIC profile will be created for every involved data center and network
   and
 - the networks will be assigned to every cluster that has that external
   provider as the default provider.
 - All users are allowed to use the new vNIC Profile.

Comment 1 Dominik Holler 2017-11-10 12:07:18 UTC
The default value of the new property is 'true', that means that the auto sync is enabled by default.

Comment 2 Red Hat Bugzilla Rules Engine 2017-11-22 09:02:23 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 3 Red Hat Bugzilla Rules Engine 2017-12-12 10:02:51 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 5 Mor 2018-01-25 14:23:25 UTC
I am currently running RHV 4.2.1.3-0.1.el7, but I do not any checkbox for enabling it. I am running the latest RHV build (BUILD VERSION: 4.2.1-5 [TARGET MILESTONE: ovirt-4.2.1] [25-01-2018])

Comment 6 Dominik Holler 2018-01-25 15:45:09 UTC
Currently, the property is only available in rest-api and not available in webadmin. For backward compatibility, the property is set to 'disabled' by default in rest-api and webadmin. If you think the property should be available in webadmin, please create a bug with a proposed default value to track this.

Comment 7 Dominik Holler 2018-02-16 16:08:25 UTC
Created attachment 1397090 [details]
Example to enable auto-synv on the REST-API via the oVirt python sdk

Comment 8 Mor 2018-02-22 11:52:56 UTC
Hi Dominik,

The fix for the blocker bug: https://bugzilla.redhat.com/show_bug.cgi?id=1539765 is not merged yet on the current RHV version. Could you please change the status to MODIFIED?

Comment 9 Michael Burman 2018-05-29 05:42:54 UTC
Verified on - 4.2.4-0.1.el7

Comment 10 Sandro Bonazzola 2018-06-26 08:38:14 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.