Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511506

Summary: Doc RFE - Document how to set the readdir-chunk option
Product: Red Hat Gluster Storage Reporter: Anjana Suparna Sriram <asriram>
Component: doc-Administration_GuideAssignee: Chandrakanth Pai <chpai>
doc-Administration_Guide sub component: Default QA Contact: Manisha Saini <msaini>
Status: CLOSED CURRENTRELEASE Docs Contact:
Severity: unspecified    
Priority: unspecified CC: asriram, bturner, chpai, dang, ffilz, jthottan, kkeithle, mbenjamin, msaini, nlevinki, rhinduja, rhs-bugs, rwheeler, sankarshan, skoduri, storage-doc
Version: rhgs-3.4Keywords: Documentation, FutureFeature
Target Milestone: ---   
Target Release: RHGS 3.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-10 15:27:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1503140    

Description Anjana Suparna Sriram 2017-11-09 13:30:49 UTC
Additional information: 

Use Case Description: 

As an administrator, I want to know how I can set the readdir-chunk option so that I can complete command operations quickly.

This use case includes documenting the following content:

Provide brief overview information about the performance improvements available by setting the readdir-chunk option to provide task information that describes where and how to set the readdir-chunk option to provide a list of options that are required to be enabled/set in order to implement readdir-chunk

PoC: Frank/Kaleb/Soumya

Comment 2 Frank Filz 2017-12-15 17:36:44 UTC
Are you looking for good values to use, or how to configure? On the latter part, dirent chunking becomes the default with it's introduction to the code base. For tuning, I haven't done any work.

Comment 5 Frank Filz 2018-02-07 14:26:54 UTC
So far based on Ambarish's testing, it seems that the default of 128 is the sweet spot (lucky choice on my part I guess). At this point I would not advise tuning this option.

Comment 7 Anjana Suparna Sriram 2018-02-16 07:18:10 UTC
*** Bug 1518170 has been marked as a duplicate of this bug. ***

Comment 12 Daniel Gryniewicz 2018-03-05 15:03:14 UTC
I think at the moment we don't recommend anyone change it.

Comment 13 Kaleb KEITHLEY 2018-03-06 15:47:51 UTC
We seem to be going around in circles on this. I'm not sure why.

It is a setting that _can_ be changed. We strongly suggest (recommend) that it be left at the default setting of 128. We don't have any guidance at this time for the circumstances under which anyone should change it, or what they should change it to.

But if a user wants to experiment, they certainly may.

AFAIK we don't have any "secret" or undocumented settings. And even if we do, people can look at the source to find it. The best we can do is document that it is a setting, and we think it should be left at the default value of 128.

Either that, or don't document it. At all, or ever, or until we have advice for when to set it to something else.

Comment 14 Ambarish 2018-03-06 15:54:55 UTC
(In reply to Kaleb KEITHLEY from comment #13)
> We seem to be going around in circles on this. I'm not sure why.
> 
> It is a setting that _can_ be changed. We strongly suggest (recommend) that
> it be left at the default setting of 128. We don't have any guidance at this
> time for the circumstances under which anyone should change it, or what they
> should change it to.
> 
> But if a user wants to experiment, they certainly may.
> 
> AFAIK we don't have any "secret" or undocumented settings. And even if we
> do, people can look at the source to find it. The best we can do is document
> that it is a setting, and we think it should be left at the default value of
> 128.
> 
> Either that, or don't document it. At all, or ever, or until we have advice
> for when to set it to something else.

+1.

As mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1511506#c6 , I think we can go ahead document how to tweak it , with a very clear recommendation of NOT to tweak it.

Comment 15 Frank Filz 2018-03-06 18:28:11 UTC
(In reply to Ambarish from comment #14)
> (In reply to Kaleb KEITHLEY from comment #13)
> > We seem to be going around in circles on this. I'm not sure why.
> > 
> > It is a setting that _can_ be changed. We strongly suggest (recommend) that
> > it be left at the default setting of 128. We don't have any guidance at this
> > time for the circumstances under which anyone should change it, or what they
> > should change it to.
> > 
> > But if a user wants to experiment, they certainly may.
> > 
> > AFAIK we don't have any "secret" or undocumented settings. And even if we
> > do, people can look at the source to find it. The best we can do is document
> > that it is a setting, and we think it should be left at the default value of
> > 128.
> > 
> > Either that, or don't document it. At all, or ever, or until we have advice
> > for when to set it to something else.
> 
> +1.
> 
> As mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1511506#c6 , I
> think we can go ahead document how to tweak it , with a very clear
> recommendation of NOT to tweak it.

+1

Comment 16 Kaleb KEITHLEY 2018-05-03 11:46:15 UTC
If you must have additional words, then probably something like

"Do not change this setting without doing extensive testing of your work load."

Comment 26 Manisha Saini 2018-08-30 17:04:43 UTC
Verified. The changes has been reverted.
Thanks