Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511503

Summary: you need to download more than 3MB to display one page, on 6.2 it was 1MB
Product: Red Hat Satellite 6 Reporter: Jan Hutař <jhutar>
Component: WebUIAssignee: satellite6-bugs <satellite6-bugs>
WebUI sub component: Foreman QA Contact: Ranjan Kumar <rankumar>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: unspecified CC: aperotti, bbuckingham, dcaplan, dlobatog, ehelms, jhutar, mhulan, mmccune, ohadlevy, pcreech, rankumar, sgraessl, tbrisker
Version: 6.3.0Keywords: PrioBumpField, Regression, Triaged
Target Milestone: 6.3   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1572300 (view as bug list) Environment:
Last Closed: 2018-06-19 20:17:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
comparasion of transfered sizes og 6.2.0 to 6.3.0
none
page load profile
none
detailed page load profile none

Description Jan Hutař 2017-11-09 13:29:40 UTC
Created attachment 1349928 [details]
comparasion of transfered sizes og 6.2.0 to 6.3.0

Description of problem:
You need to download more than 3MB to display one page. In Sat 6.2 it was 1MB


Version-Release number of selected component (if applicable):
Sat 6.3.0: satellite-6.3.0-21.0.beta.el7sat.noarch
Sat 6.2.0: satellite-6.2.12-6.0.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Have a Satellite with 9 registered content hosts
2. Go to https://sat630.example.com/content_hosts
3. In Firefox, press F12 to open developer console, switch to "Network" tab
   and click button with rounded icon to start performance analysis
4. Click to address bar and press Enter 3 times so we have nice summary we
   can use to measure average


Actual results:
We are interested in "Primed cache" graph. In my case, it shows "Transferred Size: 10,959.01 KB", that is 3.6 MB per page load.

If I do the same on Satellite 6.2 (also with 9 content hosts), is shows "Transferred Size: 3,287.75 KB", so about 1.1 MB per page load.


Expected results:
Besides page load should not require that much data, it should not be more that 3 times state in Satellite 6.2

Comment 3 jcallaha 2017-11-14 18:32:35 UTC
Can you provide a more detailed breakdown of what constitutes the 1MB and 3MB downloads for each? Also, does that download scale up with the amount of hosts you have?

Comment 4 Jan Hutař 2017-11-14 20:04:26 UTC
Hello Jake. As I said: I had only 9 registered content hosts and I was accessing .../content_hosts page. And I doubt number would go up with more hosts significantly as JavaScript caused 95% of the amount.

Comment 5 jcallaha 2017-12-13 21:52:33 UTC
I'm currently seeing 4.5mb downloaded with 20 content hosts actively loaded on the page. The system has a total of 5668 content hosts registered. 
See attached screenshot for more detailed breakdown.

Comment 6 jcallaha 2017-12-13 21:54:23 UTC
Created attachment 1367593 [details]
page load profile

Comment 7 jcallaha 2017-12-13 21:57:16 UTC
Created attachment 1367595 [details]
detailed page load profile

it looks like bundle.js makes up the vast majority of the transferred data, weighing in at 3.4mb

Comment 11 Daniel Lobato Garcia 2017-12-21 09:17:27 UTC
bundle.js is obviously cached after the 1st request, could you give us some measures of what pages exactly got slower, and if it happens always or under special circumstances?

Comment 12 Tomer Brisker 2018-02-08 13:03:11 UTC
Looks like bundle.js is served by apache and isn't cached, while other js files are served by passanger and properly cached. bundle.css is also served by apache and is cached.

For some reason, If-Modified-Since: header isn't being sent by FF for bundle.js, so the server replies with the full file instead of a 304 Unchanged.

Chrome does recognize that it has the file in cache and doesn't even ask the server for it.

Comment 13 Tomer Brisker 2018-02-08 13:14:46 UTC
Disregard the passanger part, only html is served by passenger, js is always served by apache.

Comment 14 Ohad Levy 2018-02-28 17:02:54 UTC
also see https://bugzilla.redhat.com/show_bug.cgi?id=1550160, it looks like bundle.js is a development build vs production.

Comment 15 Patrick Creech 2018-05-23 10:51:32 UTC
This should be fixed via downstream tooling updates

Comment 16 Patrick Creech 2018-05-23 10:51:33 UTC
This should be fixed via downstream tooling updates

Comment 17 Ranjan Kumar 2018-05-30 08:32:34 UTC
Verified! on Satellite 6.3.2 1.0

@satellite 6.3 snap 1.0

Data Transferred
----------------------

On Satellite 6.2.14
 23 requests, 5.89 MB(transferred: 1.49 MB) 21.05s
 bundle.js not found in response

On Satellite 6.3.0
 33 requests, 18.55 MB(transferred: 4.09 MB) 58.21s
  bundle.js Total Size: 15.12 MB and Transferred Size: 3.35 MB 
 
On Satellite 6.3.2 Snap 1
 35 requests, 5.93 MB(transferred: 1.46 MB) 27.44  
 bundle.js Total Size: 2.48 MB and Transferred Size: 686.14KB 

I think request time took more in sanp because the host count is high in Snap compare to 6.2.14
  
All screen attached.

Behavior:

Satellite 6.3.2 1.0 transferred sizes are less compare to 6.2.14 and 6.3.0

Comment 22 errata-xmlrpc 2018-06-19 20:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1950

Comment 23 Mike McCune 2019-01-25 17:46:26 UTC
*** Bug 1550160 has been marked as a duplicate of this bug. ***