Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511425

Summary: what is the purpose of _selinux man page?
Product: Red Hat Enterprise Linux 7 Reporter: Milos Malik <mmalik>
Component: policycoreutilsAssignee: Vit Mojzis <vmojzis>
Status: CLOSED WONTFIX QA Contact: Milos Malik <mmalik>
Severity: low Docs Contact:
Priority: low    
Version: 7.5CC: dapospis, dwalsh, herrold, lvrabec, mgrepl, mmalik, plautrba, ssekidde, zpytela
Target Milestone: rcKeywords: EasyFix
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-27 14:06:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Milos Malik 2017-11-09 10:22:56 UTC
Description of problem:
* there is a _selinux man page which does not say much, but it mentions svirt
* certain man pages are generated, is it possible that some pattern/variable was not expanded during the man page generation?

Version-Release number of selected component (if applicable):
selinux-policy-doc-3.13.1-166.el7.noarch
selinux-policy-targeted-3.13.1-166.el7.noarch
selinux-policy-3.13.1-166.el7.noarch
selinux-policy-devel-3.13.1-166.el7.noarch

How reproducible:
* always

Steps to Reproduce:
# yum -y install selinux-policy-doc
# man _selinux

Comment 1 Milos Malik 2017-11-09 10:25:11 UTC
_selinux(8)				SELinux Policy				    _selinux(8)



NAME
       _selinux - Security Enhanced Linux Policy for the  processes

DESCRIPTION
       _t SELinux domain type is now associated with svirt domain type (svirt_t).

       Please see

       svirt_selinux

       man page for more details.


COMMANDS
       semanage fcontext can also be used to manipulate default file context mappings.

       semanage permissive can also be used to manipulate whether or not a process type is per‐
       missive.

       semanage module can also be used to enable/disable/install/remove policy modules.


       system-config-selinux is a GUI tool available to customize SELinux policy settings.


AUTHOR
       This manual page was auto-generated using sepolicy manpage .


SEE ALSO
       selinux(8),   svirt(8),	 semanage(8),	restorecon(8),	  chcon(1),    sepolicy(8)    ,
       svirt_kvm_net_selinux(8),       svirt_kvm_net_selinux(8),      svirt_lxc_net_selinux(8),
       svirt_lxc_net_selinux(8),     svirt_qemu_net_selinux(8),	     svirt_qemu_net_selinux(8),
       svirt_socket_selinux(8),		 svirt_socket_selinux(8),	  svirt_tcg_selinux(8),
       svirt_tcg_selinux(8)



					    17-07-10				    _selinux(8)

Comment 2 Milos Malik 2017-11-09 15:08:34 UTC
# rm -f /tmp/*.8
# ls -l /tmp/*.8
ls: cannot access /tmp/*.8: No such file or directory
# sepolicy manpage -d httpd_t
/tmp/apache_selinux.8
/tmp/httpd_selinux.8
# ls -l /tmp/*.8
-rw-r--r--. 1 root root    24 Nov  9 16:06 /tmp/apache_selinux.8
-rw-r--r--. 1 root root 36281 Nov  9 16:06 /tmp/httpd_selinux.8
-rw-r--r--. 1 root root  1051 Nov  9 16:06 /tmp/_selinux.8
#

Comment 3 Milos Malik 2017-11-09 15:12:53 UTC
# rm -f /tmp/*.8
# ls -l /tmp/*.8
ls: cannot access /tmp/*.8: No such file or directory
# sepolicy manpage -d svirt_t
/tmp/svirt_selinux.8
# ls -l /tmp/*.8
-rw-r--r--. 1 root root 1082 Nov  9 16:12 /tmp/_selinux.8
-rw-r--r--. 1 root root 9975 Nov  9 16:12 /tmp/svirt_selinux.8
#

Comment 4 Zdenek Pytela 2019-02-27 14:06:36 UTC
This issue was not selected to be included in Red Hat Enterprise Linux 7.7 because it is seen either as low or moderate impact to a small number of use-cases. The next release will be in Maintenance Support 1 Phase, which means that qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available.

We will now close this issue, but if you believe that it qualifies for the Maintenance Support 1 Phase, please re-open; otherwise, we recommend moving the request to Red Hat Enterprise Linux 8 if applicable.