Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1511133

Summary: Backport missing commit for BZ#1315266 - uses USR1 signal to handle log rotation
Product: Red Hat Satellite 6 Reporter: Neal Kim <nkim>
Component: PackagingAssignee: Dmitri Dolguikh <ddolguik>
Status: CLOSED CURRENTRELEASE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 6.2.12CC: bbuckingham, cdonnell, dcaplan, gapatil, michael.orlov, mmccune, phess, vincent.vandecamp
Target Milestone: 6.2Keywords: PrioBumpGSS, PrioBumpPM, Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
URL: https://github.com/theforeman/foreman-packaging/pull/1058
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-08 21:42:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Neal Kim 2017-11-08 18:11:25 UTC
Description of problem:

After all that hard work for smart-proxy to support log rotation with SIGUSR1, it seems the accompanying logrotate scripts were not updated.

It seems we are missing a commit from BZ#1315266, specifically:

https://github.com/theforeman/foreman-packaging/pull/1058


Version-Release number of selected component (if applicable):

foreman-proxy-1.11.0.7-1.el7sat.noarch


How reproducible:

Always.


Steps to Reproduce:

1. For RHEL 7
2. /etc/logrotate.d/foreman-proxy
2. postrotate still uses try-restart instead of --signal=SIGUSR1


Actual results:

Not using SIGUSR1


Expected results:

Using SIGUSR1


Additional info:

Comment 2 pm-sat@redhat.com 2017-11-08 19:19:18 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 3 pm-sat@redhat.com 2017-11-08 19:19:20 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/12295 has been resolved.

Comment 6 Mike McCune 2018-03-08 21:42:18 UTC
This is resolved in Satellite 6.3. If you have upgraded and are still
seeing this issue, please feel free to re-open and provide additional
information about the issue.