Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1510629

Summary: Missing adcli on Modular compose
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: fedora-modular-releaseAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 27CC: gmarr, kevin, sgallagh, sumukher
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-13 13:02:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1502880    

Description Stephen Gallagher 2017-11-07 20:55:48 UTC
Description of problem:
realmd (and by extension, Cockpit) requires the `adcli` tool to join Windows Active Directory domains. This package is currently missing from the Modular compose.

Version-Release number of selected component (if applicable):
Fedora-Modular-27-20171105.n.3

How reproducible:
Every time

Steps to Reproduce:
1. Install from Fedora-Modular-27-20171105.n.3
2. `dnf install adcli`

Actual results:
No match for argument: adcli


Expected results:
adcli package should be installed


Additional info:

Comment 1 Fedora Blocker Bugs Application 2017-11-07 20:57:00 UTC
Proposed as a Blocker for 27-server-beta by Fedora user sgallagh using the blocker tracking app because:

 "It must be possible to log in to the default Cockpit instance and use it to [...] Enrol the system to a FreeIPA or Active Directory domain" -- Beta Criteria

Comment 2 Kevin Fenzi 2017-11-07 22:01:40 UTC
+1 blocker.

Comment 3 Stephen Gallagher 2017-11-08 01:47:35 UTC
This is on its way to the Beta 1.3 compose. I will update the BZ to ON_QA once that compose completes.

Comment 4 Stephen Gallagher 2017-11-08 13:43:18 UTC
This is fixed in RC 1.3 (which due to a rel-eng mishap did not fully complete, but the ISO images are present, so this can be verified).

Comment 5 Geoffrey Marr 2017-11-08 15:27:42 UTC
Discussed during the 2017-11-07 server SIG meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made.

[1] https://meetbot.fedoraproject.org/teams/serversig/serversig.2017-11-07-21.01.html

Comment 6 sumantro 2017-11-09 15:09:52 UTC
Not reproducible. This works fine :)

Comment 7 Stephen Gallagher 2017-11-13 13:02:43 UTC
(In reply to sumantro from comment #6)
> Not reproducible. This works fine :)

Marking this bug as fixed.