Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1510282

Summary: Fail to assign configured IP addresses to network boot systems
Product: [Fedora] Fedora Reporter: Yu Watanabe <watanabe.yu+redhat.bugzilla>
Component: dnsmasqAssignee: Petr Menšík <pemensik>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 27CC: dougsland, dustymabe, itamar, jima, laine, pavlix, p, pemensik, thozza, veillard
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-08 11:00:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Yu Watanabe 2017-11-07 06:19:32 UTC
Description of problem:

When starting network boot system, expected IP address cannot assigned to the system, and dnsmasq logs the following
====
Nov 06 20:05:31 dnsmasq-dhcp[26231]: not giving name hk17.yukawa.kyoto-u.ac.jp to the DHCP lease of 192.168.0.218 because the name exists in /etc/hosts with address 192.168.0.17
Nov 06 20:05:31 dnsmasq-dhcp[26231]: not giving name hk17 to the DHCP lease of 192.168.0.218 because the name exists in /etc/hosts with address 192.168.0.17
====
In /etc/hosts, the hostname hk17 and its IP address 192.168.0.17 is listed.
In /etc/ethers, the MAC address of hk17 is listed.
Below is my dnsmasq.conf.
====
no-resolv
server=192.168.30.41@publicnet
server=192.168.30.42@publicnet
interface=localnet
listen-address=192.168.0.1
bind-interfaces
expand-hosts
domain=yukawa.kyoto-u.ac.jp
dhcp-range=192.168.0.200,192.168.0.250,255.255.255.0,12h
read-ethers
dhcp-option=option:ntp-server,133.3.201.227
dhcp-match=set:bios,option:client-arch,0
dhcp-match=set:efi-x86_32,option:client-arch,6
dhcp-match=set:efi-x86_64,option:client-arch,7
dhcp-match=set:efi-x86_64,option:client-arch,9
dhcp-match=set:ipxe,175 # iPXE sends a 175 option.
dhcp-boot=tag:!ipxe,tag:bios,undionly.kpxe
dhcp-boot=tag:!ipxe,tag:efi-x86_32,ipxe-i386.efi
dhcp-boot=tag:!ipxe,tag:efi-x86_64,ipxe-x86_64.efi
dhcp-boot=tag:ipxe,http://${dhcp-server}/repo/settings/pxeboot/boot.php
dhcp-option=encap:175, 176, 1b       # no-proxydhcp
enable-tftp
tftp-root=/usr/share/ipxe
dhcp-authoritative
====

Version-Release number of selected component (if applicable):

dnsmasq-0:2.77-9.fc27.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. setup /etc/hosts, /etc/ethers and /etc/dnsmasq.conf as the above.
2. boot network booting system.
3.

Actual results:

The client system cannot obtain IP address specified in /etc/hosts.

Expected results:

The client system obtains expected IP address.

Additional info:

This is caused http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=5ce3e76fbf89e942e8c54ef3e3389facf0d9067a, and fixed in http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=1d224949cced9e82440d00b3dbaf32c262bac2ff.
Please update to dnsmasq-2.78 (or downgrade to 2.76).

Comment 1 Petr Menšík 2018-01-08 11:00:59 UTC
Fedora 27 received that update already as well as Rawhide. I just forgot to add this bug. Because mentioned commit is not yet in Fedora 26 version, I consider it fixed. Thank you for commit search.