Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1508281

Summary: Smart State Analysis doesn't show data in "Patches" and "Registry Entries" etc for Windows VM.
Product: Red Hat CloudForms Management Engine Reporter: tachoi
Component: SmartState AnalysisAssignee: Jerry Keselman <jkeselma>
Status: CLOSED CURRENTRELEASE QA Contact: Satyajit Bulage <sbulage>
Severity: high Docs Contact:
Priority: high    
Version: 5.8.0CC: agrare, dajohnso, djoo, gblomqui, jhardy, jkeselma, mfeifer, obarenbo, roliveri, sbulage, simaishi
Target Milestone: GAKeywords: TestOnly, ZStream
Target Release: 5.9.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.9.0.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1519910 (view as bug list) Environment:
Last Closed: 2018-03-06 15:27:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1519910    

Description tachoi 2017-11-01 03:46:31 UTC
Description of problem:
Created Default Analysis Profiles 
Did SSA against windows instance in Azure cloud 
- managed disk, storage account level encryption
But SSA result doesn't include 
* Files
* Registry Entries
* Patches

Version-Release number of selected component (if applicable):
Target Windows version:  Windows Server 2012 R2 Datacenter
cfme-5.8.1.5-11.el7cf.x86_64
cfme-gemset-5.8.1.5-15.el7cf.x86_64

How reproducible:
1. Spin-up Windows(Windows Server 2012 R2 Datacenter) VM from Azure cloud
- managed disk, storage account level encryption 
2.Create default Analysis Profiles from CFME 
3.Do SSA against this VM

Steps to Reproduce:
1.
2.
3.

Actual results:
Not showing related info from VM summary view

Expected results:
Showing related info from VM summary view

Additional info:

Comment 15 Marianne Feifer 2017-11-02 14:33:47 UTC
Rich, what's the answer regarding patches for windows vms?

Comment 28 Satyajit Bulage 2017-12-08 12:25:02 UTC
SSA is able to fetch "Patch" and "Registry Entries" etc for Windows VM.

Verified Version: 5.9.0.11.20171127204214_e316988

Comment 29 Jerry Keselman 2017-12-12 16:04:43 UTC
*** Bug 1524415 has been marked as a duplicate of this bug. ***