Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1482354

Summary: SELinux is preventing abrt-action-sav from 'map' accesses on the file /var/lib/rpm/Basenames.
Product: [Fedora] Fedora Reporter: Delete My Account <c.crispino8611>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alex.ploumistos, dominick.grift, dwalsh, lsm5, lvrabec, mgrepl, plautrba, pmatilai, pmoore, ssekidde
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9ac1753120cb1f7259e34bba13778d79549d1ae930d0c4dea51f9ff356dcc576;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-07 09:22:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Delete My Account 2017-08-17 05:37:00 UTC
Description of problem:
SELinux is preventing abrt-action-sav from 'map' accesses on the file /var/lib/rpm/Basenames.

*****  Plugin catchall (100. confidence) suggests   **************************

If si crede che abrt-action-sav dovrebbe avere possibilità€ di accesso map sui Basenames file in modo predefinito.
Then si dovrebbe riportare il problema come bug.
E' possibile generare un modulo di politica locale per consentire questo accesso.
Do
allow this access for now by executing:
# ausearch -c 'abrt-action-sav' --raw | audit2allow -M my-abrtactionsav
# semodule -X 300 -i my-abrtactionsav.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:rpm_var_lib_t:s0
Target Objects                /var/lib/rpm/Basenames [ file ]
Source                        abrt-action-sav
Source Path                   abrt-action-sav
Port                          <Sconosciuto>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           rpm-4.13.0.1-41.fc27.x86_64
Policy RPM                    selinux-policy-3.13.1-270.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.0-0.rc4.git4.1.fc27.x86_64 #1
                              SMP Fri Aug 11 15:03:46 UTC 2017 x86_64 x86_64
Alert Count                   20
First Seen                    2017-08-13 09:24:28 CEST
Last Seen                     2017-08-17 07:24:03 CEST
Local ID                      53cd839d-6d48-4a7a-9901-139566196b66

Raw Audit Messages
type=AVC msg=audit(1502947443.420:1316): avc:  denied  { map } for  pid=1514 comm="abrt-action-sav" path="/var/lib/rpm/Basenames" dev="sda4" ino=1314107 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=file permissive=0


Hash: abrt-action-sav,abrt_t,rpm_var_lib_t,file,map

Version-Release number of selected component:
selinux-policy-3.13.1-270.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.13.0-0.rc4.git4.1.fc27.x86_64
type:           libreport

Potential duplicate: bug 1480911

Comment 1 Panu Matilainen 2018-02-07 09:22:19 UTC

*** This bug has been marked as a duplicate of bug 1513720 ***