Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1470

Summary: need summary
Product: [Retired] Red Hat Linux Reporter: vasz
Component: egcsAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-18 21:51:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description vasz 1999-03-10 15:44:45 UTC
Either the kernel, or rather the C compiler
and library in 5.2 very slow. I do numerical
calculations and when I upgraded from 5.0 to
5.2 the speed of my calculation
substationally slowed down (about on third).
When went back I have gained the speed back.
I noticed, that on alpha from 5.1 the new,
and unfortunately experimental compiler,
the egcs is used. Since I am not an
expertise in kernel compiling, I am not sure
where the problen came from. It is because
the 5.1 and 5.2 kernel was compiled with
egcs or simply the egcs does not give the
same speed as the gcc compiler. I think this
is a serious problem, since many pepole,
like myself, use the alpha station for
numerical speed.

Comment 1 Preston Brown 1999-03-18 21:51:59 UTC
We have not noticed similar performance problems here.  Without
further information, we cannot determine if there is indeed a
problem.  Please provide more information if you do reopen this bug.

Comment 2 vasz 1999-03-23 19:58:59 UTC
I used the GROMACS molecular dynamics package when
I fund this speed problem. I have repeated the
install 5.2 and do GROMACS, install 5.0 from
scratch compile GROMACS and run severeal times and
the major speed problems comes out consistently.
As I said the speed problem only comes when one
dealing with NUMERICAL (floating point)
calculations.