Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 143901

Summary: RFE: Please include hplip in FC5
Product: [Fedora] Fedora Reporter: Dawid Gajownik <gajownik>
Component: distributionAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Bill Nottingham <notting>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: kajtzu, notting, pearcec, rvokal
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://sourceforge.net/forum/forum.php?forum_id=428206
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-09 14:29:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150221    
Attachments:
Description Flags
Proposal spec file
none
Errors from install script none

Description Dawid Gajownik 2005-01-01 00:15:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5)
Gecko/20041122

Description of problem:
http://hpinkjet.sourceforge.net/ released a new drivers to HP
products. I would be nice to include then in FC4 :)

Version-Release number of selected component (if applicable):
hplip

How reproducible:
Always

Steps to Reproduce:
1. yum install hplip -> hplip not found ;)    

Additional info:
Happy New Year!

Comment 1 Dawid Gajownik 2005-01-01 00:19:55 UTC
Created attachment 109205 [details]
Proposal spec file

Well, it's my 3rd spec file in my whole life, so I think that it need to be
polished :D

Comment 2 Dawid Gajownik 2005-01-01 00:28:20 UTC
Created attachment 109206 [details]
Errors from install script

Oh, I almost forgot - when you install package without "--enable-rpm-install"
option, you will see those errors. That's why I had to write so many lines in
%install section.

Comment 3 Dawid Gajownik 2005-01-01 12:43:55 UTC
I had a sleep and now I see that I missed two things:
- Obsoletes: hpijs
- hplip should be split into two packages - driver and the GUI app.
Now hplip requires X server :/

Comment 4 Bill Nottingham 2005-01-03 06:18:51 UTC
Tim, how does this relate to both hpijs and hpoj?

Comment 5 Tim Waugh 2005-01-04 09:20:04 UTC
It's newer than both.  I'm watching it already, but waiting until the "new
project" bugs are shaken out before switching Fedora Core over to it.

Comment 6 Jeff Moe (jebba) 2005-02-02 21:35:36 UTC
Tim, can you put it in rawhide so it can be tested?

Bill: "A distribution can mix and match the HPLIP package in order to
support a un-di or bi-di solution. HPIJS is part of the HPLIP package.

HPLIP is intended to replace HPOJ for all local USB and JetDirect
connectivity. HPLIP is similar to HPOJ, but different. HPLIP has
persistent daemons (hpiod, hpssd) like HPOJ, but is more friendly.
HPLIP does not require a ptal-init setup. The "hp" backend will look
like any other CUPS backend that can be installed as needed. The
daemons use a standard init.d start/stop script." 
http://hpinkjet.sourceforge.net/hplip_readme.html

Comment 7 Tim Waugh 2005-02-02 22:07:50 UTC
It's quite a bit work than just dumping the RPM in.  When I get some
time I will take a look, but it might miss FC4.

Comment 8 Tim Waugh 2005-04-06 12:08:56 UTC
*** Bug 149775 has been marked as a duplicate of this bug. ***

Comment 9 Tim Waugh 2005-06-03 12:17:28 UTC
Retargetting for FC5.

Comment 10 Dawid Gajownik 2005-06-09 14:29:40 UTC
Fixed in Rawhide :D