Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1435

Summary: umount fails on SMB mounted filesystems.
Product: [Retired] Red Hat Linux Reporter: gte855f
Component: mountAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.2CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-27 20:16:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description gte855f 1999-03-06 00:08:15 UTC
I'm running kernel 2.2.2, RH 5.2, and have installed the
recent kernel 2.2 update rpms.  Upon reboot, the halt script
stops at the umount command.  It appears that the current
version of umount does not support smb mounted filesystems.
This caused severe data loss on my system.

Comment 1 Bill Nottingham 1999-03-22 23:49:59 UTC
what version of mount are you running?

------- Email Received From  Joshua Weage <gte855f@prism.gatech.edu> 03/22/99 19:05 -------

Comment 2 Bill Nottingham 1999-03-23 00:16:59 UTC
can you grab the mount-2.9 SRPM from Raw Hide/Starbuck and
recompile it and see if that works?

If so, we'll put it in the kernel-2.2 RPMS stuff.

------- Email Received From  Joshua Weage <gte855f@prism.gatech.edu> 03/22/99 20:43 -------


------- Email Received From  Joshua Weage <gte855f@prism.gatech.edu> 03/23/99 08:52 -------

Comment 3 Bill Nottingham 1999-03-26 16:54:59 UTC
I'm looking into why it's hanging; umount -a at the end
*should* work, especially since it works everywhere else...

Comment 4 Bill Nottingham 1999-03-26 19:59:59 UTC
Bugger. umounting smb filesystems hangs if there's no network.
Looking into patching the kernel to support umount -f for
smb.

Comment 5 Bill Nottingham 1999-03-27 20:16:59 UTC
The fix, for now, is to add a line to the nfsfs startup
script, in the stop section, that says
'umount -a -t smbfs'.
This will be fixed in the next initscripts release, which will
have a 'netfs' script that mounts and unmounts network
filesystems (smb, ncp, nfs.)
(Eventually, we'll get the kernel fixed so that you can
forcefully umount a SMB share even if the network goes away.)

Comment 6 openshift-github-bot 2016-05-17 17:28:01 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/fc33fa4733d95aa32a2844ac4d802aad9830e610
Merge pull request #1897 from sdodson/issue1435

Include sdn-ovs in upgrade commands to avoid pulling in newer packages