Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1424

Summary: XFree86-XFS comes with freetype, but no mkttfontdir
Product: [Retired] Red Hat Linux Reporter: Hans de Goede <j.w.r.degoede>
Component: XFree86Assignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0CC: j.w.r.degoede
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-22 14:57:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 1999-03-04 19:49:03 UTC
Not really a bug but wouldn't it be nice to
include mkttfontdir, since XFree now comes with truetype
support?

Also freetype or maybe it's mkttfontdir's fault generate X
font entries which netscape doesn't really like, it accepts
them but doesn't see them as scalable. Xfstt on the other
hand works with some kind of special encoding in the font
names which netscape seems to understand reasonable well.

Comment 1 Cristian Gafton 1999-03-19 18:58:59 UTC
assigned to pbrown

Comment 2 Preston Brown 1999-03-22 14:56:59 UTC
xfstt doesn't even use X compatible fonts.scale and fonts.dir,
actually it deviates from the X font specification rather majorly in
several areas.  This is why we have decided to use Xfstt instead of
xfsft.  mkttfontdir should be included in the freetype package; it is
packaged there instead of with X directly, because it most directly
relates to freetype.  Until X officially has TrueType support (instead
of our patches) this will most likely remain the case.

I know about the Netscape scaling issue, but see this more as a fault
of Netscape than of the font server.  Other programs don't have this
issue.

Comment 3 Preston Brown 1999-03-22 14:57:59 UTC
I'm sorry, where I say "use xfstt instead of xfsft" the two font
server names should be reversed.  We use xfsft not xfstt.