Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 140753

Summary: kudzu does not see iBook2 internal firewire controller
Product: [Fedora] Fedora Reporter: Ralf Ertzinger <redhat-bugzilla>
Component: kudzuAssignee: Bill Nottingham <notting>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: byte, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-30 20:12:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 121179, 150221    

Description Ralf Ertzinger 2004-11-24 17:31:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041114 Firefox/1.0

Description of problem:
The internal firewire controller of my ibook2 is not seen by kudzu (and consequently by /sbin/kmodule). lspci -vvv of the device:

0002:20:0e.0 Class 0c00: 106b:0030 (prog-if 10)
        Subsystem: 106b:0030
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 16 (3000ns min, 6000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 40
        Region 0: Memory at 00000000f5000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <available only to root>

It works with the standard ohci1394 driver.

Version-Release number of selected component (if applicable):
kudzu-1.1.96-1

How reproducible:
Always

Steps to Reproduce:
1. use fc on ibook2, try to detect fw-controller with kudzu
2.
3.
  

Actual Results:  Kudzu does not see the controller

Expected Results:  Kudzu detects controller

Additional info:

Comment 1 Bill Nottingham 2004-11-24 19:51:09 UTC
Is it still class '0c00' when the module is not loaded?

Comment 2 Ralf Ertzinger 2004-11-25 18:14:18 UTC
Yes, but it looks a bit strange (/sbin/lspci -vvn):

0002:20:0e.0 Class 0c00: 106b:0030 (rev ff) (prog-if ff)
        !!! Unknown header type 7f

Comment 3 Bill Nottingham 2004-11-28 20:29:53 UTC
It's the (prog-if ff). ohci1394 only matches cards with prog-if 0x10.

Comment 4 Ralf Ertzinger 2004-11-29 10:37:02 UTC
So this controller needs an exception rule?

Comment 5 Bill Nottingham 2004-11-29 17:07:47 UTC
Hm, maybe. I'd wonder if it would start generating false matches on other
hardware, though.

Comment 6 David Woodhouse 2005-02-17 15:39:48 UTC
Sounds like a power management thing. While devices aren't used, the
ibook can actually shut them down completely, and you end up getting
0xff back from all configuration reads. That caused problems when the
device and vendor IDs were all 0xFFFF, preventing the devices from
being detected properly -- I think we ended up caching the idents. We
should probably be caching the revision and prog-if too.

Comment 7 Bill Nottingham 2005-09-28 21:12:05 UTC
Does this still happen with rawhide kudzu? The code has been changed to use the
modules.alias directly exported by the driver.

Comment 8 Ralf Ertzinger 2005-09-29 21:27:39 UTC
No luck so far.
kernel is 2.6.13-1.1582_FC5
kudzu is 1.2.9-1

I have a line stating "alias ieee1394-controller ohci1394" in /etc/modprobe.conf

Comment 9 Bill Nottingham 2005-09-30 03:24:27 UTC
What's the modalias in

/sys/bus/pci/devices/0002:20:0e.0/

both with, and without, the module loaded?

Comment 10 Ralf Ertzinger 2005-10-01 14:44:30 UTC
Seems to be identical as far as I can tell.

Without a driver:
pci:v0000106Bd00000030sv0000106Bsd00000030bc0Csc00i10

With driver:
pci:v0000106Bd00000030sv0000106Bsd00000030bc0Csc00i10

Comment 11 Bill Nottingham 2005-10-03 18:01:17 UTC
Odd. Running 'modprobe -n -v
"pci:v0000106Bd00000030sv0000106Bsd00000030bc0Csc00i10"' correctly shows that it
will load the ohci1394 driver.

kudzu -p -b pci doesn't list the driver right?


Comment 12 Ralf Ertzinger 2005-10-03 19:30:56 UTC
It does, as a matter of fact.

class: FIREWIRE
bus: PCI
detached: 0
desc: "Apple Computer Inc. UniNorth/Pangea FireWire"
vendorId: 106b
deviceId: 0030
subVendorId: ffff
subDeviceId: ffff
pciType: 1
pcidom:    2
pcibus: 20
pcidev:  e
pcifn:  0

/sbin/kmodule, on the other hand, does not. Do I have to nuke a file somewhere?

Comment 13 Bill Nottingham 2005-10-03 19:39:32 UTC
Actually, according to that, it doesn't - there's no 'driver:' line.

Comment 14 Bill Nottingham 2006-08-30 20:12:14 UTC
This has moved out of kudzu's realm in FC5 and later - udev is solely
responsible for loading modules.