Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1385

Summary: Failed compilation (affects the regular distribution too)
Product: [Retired] Red Hat Raw Hide Reporter: enrico.scholz
Component: linuxconfAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-18 19:39:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description enrico.scholz 1999-03-01 11:41:09 UTC
Compilation at a glibc2.1/kernel 2.2 system fails at 2
locations.

1. netconf/ipx.cc _needs_ an explicit "#include
<sys/socket.h>" (else you get a lot of missing symbols).
Currently this file will be included only if there is no
GLIBC. I guess this is done because the old libc5 had
problems to include some network headers together.

2. the firewall module has no chance to compile at a
glibc2.1 system. The FAQ of this library says:

"3.16.   Why has <netinet/ip_fw.h>
disappeared?

{AJ} The corresponding Linux kernel data structures and
constants are totally different in Linux 2.0 and Linux 2.2.
This situation has to be taken care in user programs using
the firewall structures and therefore those programs (ipfw
is AFAIK the only one) should deal with this problem
themselves."

So I think the best solution is to remove the firewall
directory from the DIRS-entry in modules/Makefile.



I know there is a new linuxconf 1.13 out there but I don't
know if it has still the errors above.

Comment 1 Cristian Gafton 1999-03-18 19:39:59 UTC
Fixed in the current beta