Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 137553

Summary: evolution-data-server: multiple missing build dependencies
Product: [Fedora] Fedora Reporter: Maxim Dziumanenko <dziumanenko>
Component: evolution-data-serverAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: anvil, scop
Target Milestone: ---Keywords: EasyFix
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-01-31 18:17:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 150221    

Description Maxim Dziumanenko 2004-10-29 14:09:10 UTC
Description of problem:
evolution-data-server uses libgnomeui-2.0.pc to initialize
GNOMEUI_SERVERDIR in config.h, which specifies location of gnome_segv2
binary

Version-Release number of selected component (if applicable):
evolution-data-server-1.0.2-3

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dams 2004-12-16 23:11:42 UTC
Hijacking this report to add more packaging errors:

[anvil@gruyere ~/Desktop]# rpmbuild --rebuild
./evolution-data-server-1.0.3-2.src.rpm
[...]
checking for bison... no
checking for byacc... no
configure: error: You need bison to build evolution-data-server
erreur: Mauvais status de sortie pour
/mnt/other/BUILD/tmppath/rpm-tmp.79770 (%build)


*installing bison*

libdb makefiles dont honor the %{__cc} macro : 
cc -c -I. -I./.. -I./../dbinc [...] ../db/db_cam.c -o db_cam.o
^^ Should be gcc.

/usr/bin/ld: cannot find -lgnutls
collect2: ld returned 1 exit status

*installing gnutls-devel*

/usr/bin/ld: cannot find -lgcrypt
collect2: ld returned 1 exit status

*installing libgcrypt-devel* 

Please add a line "BuildRequires: libgcrypt-devel gnutls-devel bison"
in the spec file.

Comment 2 Ville Skyttä 2005-01-04 11:42:39 UTC
gnutls-devel should require libgcrypt-devel (and does in Rawhide), so no need to
"fix" that here.

The complete line I had to add to the specfile to build 1.0.3-2 is:

   BuildRequires: bison, libgnome-devel, libtool, gnutls-devel

bug 134166 reports a problem wrt. gnutls/evolution but it is not clear what the
problem is; looks like mozilla-nss will be used in the future.  Maybe that
affects the gnutls stuff here.

Comment 3 Ray Strode [halfline] 2006-01-31 18:17:58 UTC
should be fixed in tomorrow's rawhide.