Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1375

Summary: UDP recvfrom() calls return ECONNREFUSED after sendto() calls
Product: [Retired] Red Hat Linux Reporter: tfeller
Component: kernelAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-08 19:00:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tfeller 1999-03-01 04:30:24 UTC
After calling sentto() on an unconnected UDP socket
the next recvfrom() call made will return an error
with errno set to ECONNREFUSED.
This sort of an error from an unconnected UDP socket
makes no sense and it is not documented in the man pages.
I have a fairly simple C test program that demonstrates
this problem that I can make available upon request.  This
test program works fine on other unix platforms including
BSDI, SCO OpenServer, SCO UnixWare and DGUX.
I am seeing lots of confusion in the news groups about this
problem.

Comment 1 Bill Nottingham 1999-03-08 19:00:59 UTC
It's not a bug, it's a feature; it's returning the error
from the previous UDP call. See RFC1122, sect. 4.1.3.3.

If you want the BSD socket behavior, you need to set the
SO_BSDCOMPAT socket option.

------- Email Received From  "Thomas J. Feller" <tfeller@execpc.com> 03/08/99 17:39 -------

Comment 2 tfeller 1999-03-18 21:41:59 UTC
If is is a feature than it should be clearly documented in the man
pages.  Are you saying that I need to figure out how the function
calls work by inferring their behavior from RFCs?  If so which RFCs
apply to Red Hat Linux 5.2?