Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1366885

Summary: Error messages just after restart. Firefox not able to play YT videos
Product: [Fedora] Fedora Reporter: Tomasz Kłoczko <kloczko.tomasz>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: gecko-bugs-nobody, jhorak, pjasicek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-30 20:14:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tomasz Kłoczko 2016-08-14 06:49:18 UTC
Description of problem:

Time tio time Firefox is not able to play YT videos. Sometimes help restart (but sometimes not).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start firefox
2. Play https://www.youtube.com/watch?v=QZTCEO0gvLo
3. Error message "Your web browser does ot currently recognize any of the video formats available"
 
Actual results:


Expected results:


Additional info:

Lines from "journalctl -ab | grep firefox" added after restart firefox:

Aug 14 07:29:30 domek firefox.desktop[7191]: WebGL(0x7f3837c84800)::ForceLoseContext
Aug 14 07:29:30 domek firefox.desktop[7191]: WebGL(0x7f385878d800)::ForceLoseContext
Aug 14 07:29:30 domek firefox.desktop[7191]: WebGL(0x7f382d2a7800)::ForceLoseContext
Aug 14 07:31:21 domek firefox.desktop[7191]: console.error: itmemory:
Aug 14 07:31:21 domek firefox.desktop[7191]:   Message: TypeError: tab is undefined
Aug 14 07:31:21 domek firefox.desktop[7191]:   Stack:
Aug 14 07:31:21 domek firefox.desktop[7191]:     getBrowserForTab@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/tabs/utils.js:198:1
Aug 14 07:31:21 domek firefox.desktop[7191]: report/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://jid1-frvglzkoncspew-at-jetpack/lib/main.js:230:20
Aug 14 07:31:21 domek firefox.desktop[7191]: notify@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/timers.js:40:9
Aug 14 07:35:32 domek firefox.desktop[31426]: ATTENTION: default value of option force_s3tc_enable overridden by environment.


Other errors sequences whic I found in logs:

Aug 13 21:30:58 domek firefox.desktop[4373]: ATTENTION: default value of option force_s3tc_enable overridden by environment.
Aug 13 21:46:39 domek firefox.desktop[4373]: console.error:
Aug 13 21:46:39 domek firefox.desktop[4373]:   Message: InternalError: too much recursion
Aug 13 21:46:39 domek firefox.desktop[4373]:   Stack:
Aug 13 21:46:39 domek firefox.desktop[4373]:     onEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:42:18
Aug 13 21:46:39 domek firefox.desktop[4373]: onChromeEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:91:16
Aug 13 21:46:43 domek firefox.desktop[4373]: console.error:
Aug 13 21:46:43 domek firefox.desktop[4373]:   Message: InternalError: too much recursion
Aug 13 21:46:43 domek firefox.desktop[4373]:   Stack:
Aug 13 21:46:43 domek firefox.desktop[4373]:     onEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:42:18
Aug 13 21:46:43 domek firefox.desktop[4373]: onChromeEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:91:16
Aug 13 21:46:44 domek firefox.desktop[4373]: console.error:
Aug 13 21:46:44 domek firefox.desktop[4373]:   Message: InternalError: too much recursion
Aug 13 21:46:44 domek firefox.desktop[4373]:   Stack:
Aug 13 21:46:44 domek firefox.desktop[4373]:     onEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:44:16
Aug 13 21:46:44 domek firefox.desktop[4373]: onChromeEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:91:16
Aug 13 21:46:45 domek firefox.desktop[4373]: console.error:
Aug 13 21:46:45 domek firefox.desktop[4373]:   Message: InternalError: too much recursion
Aug 13 21:46:45 domek firefox.desktop[4373]:   Stack:
Aug 13 21:46:45 domek firefox.desktop[4373]:     onEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/loader/sandbox.js -> resource://gre/modules/commonjs/sdk/content/content-worker.js:42:18



Aug 13 21:47:13 domek firefox.desktop[4373]:   Message: [Exception... "Could not convert Native argument arg 0 [nsIContentFrameMessageManager.content]"  nsresult: "0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/remote/child.js :: Frame<.content :: line 170"  data: no]
Aug 13 21:47:13 domek firefox.desktop[4373]:   Stack:
Aug 13 21:47:13 domek firefox.desktop[4373]:     Frame<.content@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/remote/child.js:170:12
Aug 13 21:47:13 domek firefox.desktop[4373]: FrameList<.getFrameForWindow@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/remote/child.js:237:1
Aug 13 21:47:13 domek firefox.desktop[4373]: topicListener@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/content/tab-events.js:30:15
Aug 13 21:47:13 domek firefox.desktop[4373]: Observer<.observe@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/system/events.js:81:7
Aug 13 21:47:13 domek firefox.desktop[4373]: get_contentWindow@chrome://global/content/bindings/browser.xml:436:54
Aug 13 21:47:13 domek firefox.desktop[4373]: get_outerWindowID@chrome://global/content/bindings/browser.xml:404:11
Aug 13 21:47:13 domek firefox.desktop[4373]: tabbrowser_XBL_Constructor@chrome://browser/content/tabbrowser.xml:4475:13
Aug 13 21:47:13 domek firefox.desktop[4373]: openModalWindow@resource://gre/components/nsPrompter.js:360:5
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.openPrompt@resource://gre/components/nsPrompter.js:550:9
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:694:9
Aug 13 21:47:13 domek firefox.desktop[4373]: Prompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:79:16
Aug 13 21:47:13 domek firefox.desktop[4373]: onxblkeypress@chrome://global/content/bindings/browser.xml:1321:33
Aug 13 21:47:13 domek firefox.desktop[4373]: openModalWindow@resource://gre/components/nsPrompter.js:360:5
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.openPrompt@resource://gre/components/nsPrompter.js:550:9
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:694:9
Aug 13 21:47:13 domek firefox.desktop[4373]: Prompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:79:16
Aug 13 21:47:13 domek firefox.desktop[4373]: onxblkeypress@chrome://global/content/bindings/browser.xml:1321:33
Aug 13 21:47:13 domek firefox.desktop[4373]: openModalWindow@resource://gre/components/nsPrompter.js:360:5
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.openPrompt@resource://gre/components/nsPrompter.js:550:9
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:694:9
Aug 13 21:47:13 domek firefox.desktop[4373]: Prompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:79:16
Aug 13 21:47:13 domek firefox.desktop[4373]: onxblkeypress@chrome://global/content/bindings/browser.xml:1321:33
Aug 13 21:47:13 domek firefox.desktop[4373]: openModalWindow@resource://gre/components/nsPrompter.js:360:5
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.openPrompt@resource://gre/components/nsPrompter.js:550:9
Aug 13 21:47:13 domek firefox.desktop[4373]: ModalPrompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:694:9
Aug 13 21:47:13 domek firefox.desktop[4373]: Prompter.prototype.confirmEx@resource://gre/components/nsPrompter.js:79:16
Aug 13 21:47:13 domek firefox.desktop[4373]: onxblkeypress@chrome://global/content/bindings/browser.xml:1321:33
Aug 13 21:47:13 domek firefox.desktop[4373]: openModalWindow@resource://gre/components/nsPrompter.js:360:5

Comment 1 Tomasz Kłoczko 2016-11-30 20:14:54 UTC
Closing. Cannot reproduce this bug now.