Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1366539

Summary: No graphical display for inputting disk encryption password on boot since last kernel update
Product: [Fedora] Fedora Reporter: Louis <me>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 24CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab, me
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-10-03 11:11:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Louis 2016-08-12 09:31:43 UTC
Description of problem:
Since the latest kernel update (4.6.5-300.fc24.x86_64), the graphical display for inputting disk encryption password on boot (Plymouth?) no-longer appears. Instead, I get a black screen and once I press esc, I get a command-line prompt to enter the password.

How reproducible:
I completely reinstalled Fedora using the latest live image. I kept my /home LVM but nothing else.
The issue persists after reinstallation which is why I believe the problem has started since the latest kernel update (which is included in the latest live image).

Prior to reinstalling Fedora, I booted into the previous kernel and the graphical prompt DID appear, which is why I believe this is a kernel problem.

Steps to Reproduce:
1. Have an encrypted drive
2. Have latest kernel
3. Reboot

Actual results:
Get a command-line prompt to enter disk password after pressing esc.

Expected results:
Graphical prompt to enter disk password should appear without having to press anything.

Comment 1 Laura Abbott 2016-09-23 19:18:40 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.
 
Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 25, and are still experiencing this issue, please change the version to Fedora 25.
 
If you experience different issues, please open a new bug report for those.