Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1366207

Summary: [RFE] gdeploy should add all the repos in one go, rather than adding them serially
Product: Red Hat Gluster Storage Reporter: SATHEESARAN <sasundar>
Component: gdeployAssignee: Sachidananda Urs <surs>
Status: CLOSED WONTFIX QA Contact: SATHEESARAN <sasundar>
Severity: high Docs Contact:
Priority: unspecified    
Version: rhgs-3.1CC: amukherj, rhs-bugs, smohan, storage-qa-internal, surs
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-27 07:59:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description SATHEESARAN 2016-08-11 10:00:57 UTC
Description of problem:
-----------------------
When trying to add more than 1 repos, gdeploy does add these channels one after the other which is costliest operation and takes more time too.

gdeploy could add all these repos in one go, using 'subscription-manager repos --enable=repo1 --enable=repo2 --enable=repo3'

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0-16

How reproducible:
-----------------
NA

Steps to Reproduce:
--------------------
NA

Actual results:
---------------
gdeploy adds the mentioned repos one after other

Expected results:
------------------
gdeploy should add the repos in one go

Comment 1 SATHEESARAN 2016-09-21 16:35:32 UTC
Sac,

Are you targeting this bug for RHGS 3.2.0 ?
In that case, please mark the internal whiteboard as "3.2.0"

Comment 2 Sachidananda Urs 2016-09-22 07:04:11 UTC
(In reply to SATHEESARAN from comment #1)
> Sac,
> 
> Are you targeting this bug for RHGS 3.2.0 ?
> In that case, please mark the internal whiteboard as "3.2.0"

sas, this is not being targeted for 3.2.0. I'll fix this in the next
release after that. Hope that is OK.

Comment 3 SATHEESARAN 2016-09-26 05:34:05 UTC
(In reply to Sachidananda Urs from comment #2)
> (In reply to SATHEESARAN from comment #1)
> > Sac,
> > 
> > Are you targeting this bug for RHGS 3.2.0 ?
> > In that case, please mark the internal whiteboard as "3.2.0"
> 
> sas, this is not being targeted for 3.2.0. I'll fix this in the next
> release after that. Hope that is OK.

Sac,

Thanks for that information.

Comment 4 Sachidananda Urs 2018-03-27 07:59:56 UTC
As per disucssions with sas, this will not be fixed in gdeploy.
We will discuss this with Ansible RH-Subscription module owners. Since this the limitation of the module.