Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1365920

Summary: deluge-web depends on deluge-gtk
Product: [Fedora] Fedora Reporter: Mr. Jester <jester2.0>
Component: delugeAssignee: Michael Cronenworth <mike>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 24CC: fabrice, mike
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: deluge-1.3.13-2.fc25 deluge-1.3.13-2.fc24 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-22 05:24:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mr. Jester 2016-08-10 13:59:39 UTC
Description of problem:  deluge-web is a WebUI for the deluged daemon. This is used for headless installs.  Currently, the deluge-web package depends on deluge-gtk which depends on Xorg. There is no technical dependency for the WebUI to need the gtk client and thusly, the entire Xorg/DM environment.


Version-Release number of selected component (if applicable): deluge-web-1.3.12-3.fc24.noarch


How reproducible:  Consistent/Always


Steps to Reproduce:
1. dnf install deluge-web
2.
3.

Actual results: dnf listing entire desktop environment as a dependency for install.


Expected results: No desktop environment being installed for a webui.


Additional info:  This works as expected on Ubuntu Server.

Comment 1 Mr. Jester 2016-08-10 14:49:03 UTC
Further inspection, I have found the root cause and fix.  The deluge-web.service unit file has the wrong ExecStart value.  It should be set to 
ExecStart=/usr/bin/deluge-web -l /var/log/deluge-web.log -L warning

With this set, the /usr/bin/deluge binary is not required and you can remove the deluge-gtk dependency.

Comment 2 Fedora Update System 2016-12-20 04:19:51 UTC
deluge-1.3.13-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-324a95eb3b

Comment 3 Fedora Update System 2016-12-20 04:20:52 UTC
deluge-1.3.13-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fbfb969761

Comment 4 Fedora Update System 2016-12-20 19:21:00 UTC
deluge-1.3.13-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-324a95eb3b

Comment 5 Fedora Update System 2016-12-20 19:21:49 UTC
deluge-1.3.13-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fbfb969761

Comment 6 Fedora Update System 2016-12-22 05:24:36 UTC
deluge-1.3.13-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-12-28 21:49:16 UTC
deluge-1.3.13-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.