Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1365672

Summary: Custom product subscription shows up as "null" on activation key, unable to attach
Product: Red Hat Satellite 6 Reporter: Taft Sanders <tasander>
Component: Activation KeysAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.2.0CC: bbuckingham, bkearney, ggatward, kdixon, tomckay
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-17 00:58:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Taft Sanders 2016-08-09 19:56:35 UTC
Description of problem:
Custom product subscription shows up as "null" on activation key, unable to attach. Results in error: undefined method `redhat?' for nil:NilClass

Version-Release number of selected component (if applicable):
6.2.0

How reproducible:
everytime

Steps to Reproduce:
1.Create custom product
2.Create activation key
3.Add custom product subscription to activation key

Actual results:
undefined method `redhat?' for nil:NilClass

Expected results:
Custom subscription added to activation key

Additional info:
Workaround: Register client without activation key. Manually attach custom subscription to client.

Comment 5 Brad Buckingham 2016-08-17 00:58:14 UTC

*** This bug has been marked as a duplicate of bug 1362194 ***