Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1365395

Summary: Support for rc.d and init for Service management
Product: [Community] GlusterFS Reporter: Aravinda VK <avishwan>
Component: eventsapiAssignee: Aravinda VK <avishwan>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: mainline   
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-3.10.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1374649 (view as bug list) Environment:
Last Closed: 2017-03-06 17:22:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1351589, 1374649    

Description Aravinda VK 2016-08-09 07:39:24 UTC
Description of problem:
Current Eventsd depends on systemd service files, Add support for rc.d and init scripts.

Changes required in
gluster-eventsapi start|stop|reload|restart

Comment 1 Worker Ant 2016-08-31 03:07:49 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-09-04 11:47:54 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-09-05 12:30:49 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Worker Ant 2016-09-06 15:52:33 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Worker Ant 2016-09-08 06:16:06 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 6 Worker Ant 2016-09-08 17:39:27 UTC
REVIEW: http://review.gluster.org/15367 (eventsapi: Add Init scripts for different distributions) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 7 Worker Ant 2016-09-09 10:29:37 UTC
COMMIT: http://review.gluster.org/15367 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit 5a1abd235d05809bc7a5c4b94ae7bb51add6fc9c
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Aug 31 08:33:44 2016 +0530

    eventsapi: Add Init scripts for different distributions
    
    Added init scripts for
    - SysvInit(CentOS 6 or Red Hat 6)
    - rc.d (FreeBSD)
    
    Most of the latest distributions are using systemd. Support to be
    added for other distributions which are not using systemd.
    
    Removed systemctl wrapper functions(start/stop/status) from
    gluster-eventsapi CLI(peer_eventsapi.py). Status and Reload
    re-implemented using pid file check.
    
    Added pid file support for glustereventsd.
    
    Following dependencies removed
    python-flask - Only used for example dashboard. User can install
    if required.
    python-fasteners - Not available for EPEL 6, added custom code using
    fcntl as replacement.
    
    BUG: 1365395
    Change-Id: I26792eae9b11e93304f70b3997cd7d8d03b067f4
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15367
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 8 Shyamsundar 2017-03-06 17:22:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/