Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1365358

Summary: Kernel scheduling leads to micropauses in games
Product: [Fedora] Fedora Reporter: Turgut Kalfaoglu <turgut>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 24CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-09 11:18:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Turgut Kalfaoglu 2016-08-09 05:18:07 UTC
Description of problem:

Running games under wine-1.9.15 leads to small pauses in the game, every two seconds. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install a game under wine or crossoffice, such as World of Warcraft
2. Try the game
3. During game play, a small pause is felt every two seconds.



Additional info:
I am told that this is due to the kernel scheduling. 
The real-time kernel should be able to fix this; however, Bumblebee does not work with the RT-kernel, because the new NVIDIA drivers refuse to be compiled under the RT-kernel. Hence, Fedora should include the precompiled drivers and the RT-kernel.

Comment 1 Josh Boyer 2016-08-09 11:18:54 UTC
This bug is a huge bucket of nope.  I'm sorry, but none of the things you're asking for are something that will be done.

If you have a suspected issue with the scheduler, contacting upstream is the best solution.