Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1365314

Summary: pglogical replication fails after update through webui with RHSM
Product: Red Hat CloudForms Management Engine Reporter: luke couzens <lcouzens>
Component: ApplianceAssignee: Yuri Rudman <yrudman>
Status: CLOSED NOTABUG QA Contact: luke couzens <lcouzens>
Severity: high Docs Contact:
Priority: high    
Version: 5.6.0CC: abellott, dajohnso, jhardy, lcouzens, ncarboni, obarenbo
Target Milestone: GA   
Target Release: 5.6.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: upgrade:replication
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-16 06:50:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description luke couzens 2016-08-08 22:20:02 UTC
Description of problem: pglogical replication fails after update through webui with RHSM


Version-Release number of selected component (if applicable):5.6.1


How reproducible:100%


Steps to Reproduce:
1.Configure 2 x 5.6.0.13 appliances (region 1 and region 99)
2.Setup pglogical replication between them
3.Add latest 5.6 repo to /etc/yum.repo.d/
4.Update both appliance's through webui

Actual results: Replication fails to work afterwards


Expected results: Replication works correctly


Additional info: Validating the replication subscription on rr99 fails with authentication error.

Removing said subscription and re-adding it seems to be a work around.

Comment 2 Nick Carboni 2016-08-11 22:01:07 UTC
So is there any output in the postgres logs?

Do we know if the replication process is actually running? Can you paste in the output of `systemctl status $APPLIANCE_PG_SERVICE` for both database servers?

Also can you tell if the replication slot is still active?

Comment 3 luke couzens 2016-08-15 09:48:15 UTC
Hi Nick it seems this is fixed in 5.6.1.2 so this BZ can be closed if you are happy to, Cheers.

Comment 4 Nick Carboni 2016-08-15 19:32:30 UTC
Okay Luke, if you are sure it's fixed you can go ahead and close it.