Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364921

Summary: Multi-tenancy - not user friendly name of tenant in
Product: Red Hat CloudForms Management Engine Reporter: Pavol Kotvan <pakotvan>
Component: UI - OPSAssignee: Brian McLaughlin <bmclaugh>
Status: CLOSED CURRENTRELEASE QA Contact: Pavol Kotvan <pakotvan>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.6.0CC: dclarizi, hkataria, jhardy, mpovolny, obarenbo, simaishi
Target Milestone: GAKeywords: TestOnly
Target Release: 5.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ui:tenant_cfme
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1379692 1383336 (view as bug list) Environment:
Last Closed: 2017-06-12 17:32:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: Bug
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1379692, 1383336    

Comment 3 Harpreet Kataria 2016-08-09 13:26:00 UTC
Brian,

Looks like Tenant column needs to be fixed to show Tenant's name instead of Tenant object itself. Let me know if you need help recreating.

Thanks,
~Harpreet

Comment 4 Brian McLaughlin 2016-08-25 14:30:10 UTC
It looks like this issue was fixed in [1], please confirm.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1348630

Comment 6 CFME Bot 2016-09-23 15:15:58 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c8b7120e3e74e426599d37d9ecdc6e8a7e4b305b

commit c8b7120e3e74e426599d37d9ecdc6e8a7e4b305b
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Wed Sep 21 10:57:39 2016 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Wed Sep 21 10:57:39 2016 -0400

    Print user-friendly name of Tenant
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1364921

 app/views/miq_request/_prov_vm_grid.html.haml      |  2 +-
 .../miq_request/_prov_vm_grid.html.erb_spec.rb     | 38 ++++++++++++++++++++++
 2 files changed, 39 insertions(+), 1 deletion(-)

Comment 7 CFME Bot 2016-09-23 15:16:03 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/505d910280c4336871748f0af91e5c58913379df

commit 505d910280c4336871748f0af91e5c58913379df
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Wed Sep 21 10:59:42 2016 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Wed Sep 21 10:59:42 2016 -0400

    Update deprecated expect(response) reference
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1364921

 spec/views/miq_request/_prov_vm_grid.html.erb_spec.rb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 8 CFME Bot 2016-09-23 15:16:09 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1aea6c3550164227bf64696b064c13c629139207

commit 1aea6c3550164227bf64696b064c13c629139207
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Wed Sep 21 13:11:17 2016 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Wed Sep 21 13:11:17 2016 -0400

    style corrections
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1364921

 spec/views/miq_request/_prov_vm_grid.html.erb_spec.rb | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)