Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364758

Summary: azureus does not work after upgrade to Fedora 24
Product: [Fedora] Fedora Reporter: Nineth <udayreddy>
Component: azureusAssignee: David Juran <djuran>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 24CC: djuran, langel, sergio, udayreddy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-02-22 10:01:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nineth 2016-08-07 04:33:47 UTC
Description of problem:

azureus does not work after upgrade to Fedora 24. Reinstalling azureus (dnf reinstall) doesn't help. It looks like it's looking for jre in /usr/lib. If it needed that, the repo deps should've taken care of it.


Version-Release number of selected component (if applicable):
azureus.noarch 5.7.2.0-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Run azureus
2.
3.

Actual results:
Starting Azureus...
/usr/bin/azureus: line 55: /usr/lib/jvm/jre/bin/java: No such file or directory
Loading Azureus:
/usr/lib/jvm/jre/bin/java  -cp "/usr/lib64/eclipse/swt.jar:/usr/share/java/json_simple.jar:/usr/share/java/bcprov.jar:/usr/share/java/apache-commons-cli.jar:/usr/share/java/apache-commons-lang.jar:/usr/share/java/log4j-1.jar:/usr/share/azureus/Azureus2.jar:./Azureus2.jar" -Djava.library.path="/home/uday/.azureus/app" -Dazureus.install.path="/home/uday/.azureus/app" -Dazureus.script="/usr/bin/azureus" -Dazureus.script.version=5 -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dazureus.skipSWTcheck=1 org.gudy.azureus2.ui.swt.Main 
/usr/bin/azureus: line 91: /usr/lib/jvm/jre/bin/java: No such file or directory
Exit from Azureus complete
/usr/bin/azureus: line 55: /usr/lib/jvm/jre/bin/java: No such file or directory
Azureus TERMINATED.

Expected results:


Additional info:

Comment 1 Nineth 2016-08-07 07:13:32 UTC
Why is it looking for the jvm in that location instead of getting it from my path?

$ which java
/usr/bin/java
$ java -version
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode

Comment 2 Sergio Monteiro Basto 2016-08-08 10:49:58 UTC
ll /etc/alternatives/jre
lrwxrwxrwx 1 root root 63 Jul 29 23:12 /etc/alternatives/jre -> /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-1.b14.fc23.x86_64/jre

yours jre alternative seems broken ! not just for azureus

Comment 3 Nineth 2016-08-08 11:36:43 UTC
There is no /etc/alternatives/jre on my system, but there is

ll /etc/alternatives/java
lrwxrwxrwx 1 root root 30 Dec 31  2015 /etc/alternatives/java -> /usr/java/jre1.8.0_65/bin/java

This isn't broken. Should there have been /etc/alternatives/jre by design? Which package is supposed to create it?

Comment 4 David Juran 2016-08-16 14:59:29 UTC
Apologies for the late reply.

So /usr/lib/jvm/jre/bin/java is provided by java-1.8.0-openjdk-headless. Do you have this installed? 
rpm -q java-1.8.0-openjdk-headless

But I think I see the problem, I have a dependency towards 'java', I should have it towards openjdk specifically. Could you please give me the output of

rpm -q --whatprovides java

Comment 5 Nineth 2016-08-16 15:39:32 UTC
$ rpm -q java-1.8.0-openjdk-headless
java-1.8.0-openjdk-headless-1.8.0.101-1.b14.fc24.x86_64

$ rpm -q --whatprovides java
jre1.8.0_65-1.8.0_65-fcs.x86_64
java-1.8.0-openjdk-1.8.0.101-1.b14.fc24.x86_64

Comment 6 Nineth 2016-08-16 15:43:01 UTC
(In reply to David Juran from comment #4)
> Apologies for the late reply.
> 
> So /usr/lib/jvm/jre/bin/java is provided by java-1.8.0-openjdk-headless. Do

Apparently not.

rpm -ql java-1.8.0-openjdk-headless-1.8.0.101-1.b14.fc24.x86_64 | grep "bin/java"
/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-1.b14.fc24.x86_64/jre/bin/java

Comment 7 Sergio Monteiro Basto 2017-02-20 02:06:27 UTC
(In reply to Nineth from comment #0)

> Actual results:
> Starting Azureus...
> /usr/bin/azureus: line 55: /usr/lib/jvm/jre/bin/java: No such file or
> directory

rpm -qf /usr/lib/jvm/jre/bin/java 
java-1.8.0-openjdk-headless-1.8.0.121-1.b14.fc24.x86_64

ll /usr/lib/jvm/jre
lrwxrwxrwx 1 root root 21 Jan 28 20:40 /usr/lib/jvm/jre -> /etc/alternatives/jre
ll /etc/alternatives/jre
lrwxrwxrwx 1 root root 63 Jan 28 20:40 /etc/alternatives/jre -> /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.121-1.b14.fc24.x86_64/jre

This is not a problem with azureus is with java installation , it works for me , can we close it as "NOT A BUG" ?

Thanks

Comment 8 David Juran 2017-02-22 10:01:04 UTC
Apologies, this bug slipped my attention

Nineth: So i think it's jre1.8.0_65 package, whatever that might be, that is interfering.

Try 

alternatives --display java

That sets your default java, the one provided by fedora is the j
ava-1.8.0-openjdk

closing this a NOT_A_BUG, please feel free to reopen if I've misunderstood