Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364433

Summary: [ganesha+gdeploy]: Validate whether all nodes are up or not before starting ganesha setup.
Product: Red Hat Gluster Storage Reporter: Shashank Raj <sraj>
Component: gdeployAssignee: Sachidananda Urs <surs>
Status: CLOSED WONTFIX QA Contact: Shashank Raj <sraj>
Severity: high Docs Contact:
Priority: unspecified    
Version: rhgs-3.1CC: jthottan, kkeithle, ndevos, sashinde, skoduri, smohan, storage-qa-internal
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-23 09:30:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Shashank Raj 2016-08-05 10:44:32 UTC
Description of problem:

Validate whether all nodes are up or not before starting ganesha setup.

Version-Release number of selected component (if applicable):

Validate whether all nodes are up or not before starting ganesha setup.

How reproducible:


Steps to Reproduce:

With current design, if any one of the nodes is down while creating ganesha setup, gdeploy will still go ahead and perform all the tasks and then errors out.

We need to make sure, there is a method which checks initially whether all the nodes are up or not and then starts setting up ganesha.

If it finds out that any of the mentioned nodes is down, it should abort the ganesha setup immediately without executing anything further.

Actual results:

Expected results:

Validate whether all nodes are up or not before starting ganesha setup.

Additional info:

Comment 2 Sachidananda Urs 2016-08-16 07:55:57 UTC
I agree that machines have to be checked before starting. But I believe this is quite a bit of overkill to do it in gdeploy code. 

Because, as part of bootstrapping, user has to add ssh-keys to the nodes; which in itself validates that the nodes are up. I strongly suggest we do not do this in gdeploy, it just clutters the code.

Comment 3 Sachidananda Urs 2016-08-23 09:30:20 UTC
As per comment #2, there is no need to check the node health again from within the program. Please re-open if you still think this has to be implemented.