Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364387

Summary: Ship AppStream metadata file
Product: [Fedora] Fedora Reporter: Frank Zimmer <frank.e.zimmer>
Component: nautilus-sendtoAssignee: Bastien Nocera <bnocera>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bnocera, stickster, thunderbirdtr
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-09-29 11:03:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
addon metadata file none

Description Frank Zimmer 2016-08-05 09:07:34 UTC
Created attachment 1187800 [details]
addon metadata file

The package doesn't ship AppStream [1] metadata file, so it doesn't appear in Nautilus profile in the default app catalog GNOME Software and is not easily discoverable and installable for users.

I've already filed a bug upstream [2] because it should be ideally included there since it's used across Linux distributions, but unless/until upstream ships it it should be included downstream as the packaging guidelines say [3].

I've created the file for you, see the attachment.

[1] http://www.freedesktop.org/software/appstream/docs/sect-Quickstart-Addons.html
[2] https://bugzilla.gnome.org/show_bug.cgi?id=769539
[3] https://fedoraproject.org/wiki/Packaging:AppData

Comment 1 Onuralp SEZER 2016-08-05 09:15:15 UTC
*** Bug 1364385 has been marked as a duplicate of this bug. ***