Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364378

Summary: Add F26 GPG keys
Product: [Fedora] Fedora Reporter: Vít Ondruch <vondruch>
Component: fedora-reposAssignee: Dennis Gilmore <dennis>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dennis, dgilmore, kevin, mboddu, pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-08 12:17:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vít Ondruch 2016-08-05 08:35:02 UTC
Description of problem:
It seems that F26 keys are not shipped. This is at miminum issue for gnome-software, but I guess, that not just that:

failed to call gs_plugin_refine on packagekit-refine: Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64]



Version-Release number of selected component (if applicable):
$ rpm -q fedora-repos
fedora-repos-26-0.1.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
The F26 GPG keys are not included.

Expected results:
The F26 GPG keys are included.


Additional info:

Comment 1 Dennis Gilmore 2016-08-07 17:41:10 UTC
There is currently no f26 gpg keys

Comment 2 Vít Ondruch 2016-08-08 08:55:05 UTC
And how is the Rawhide signed then? Is the F25 key still in use? I'd say that some symlink would solve the issue for the moment.

Comment 3 Peter Robinson 2016-08-08 09:11:58 UTC
(In reply to Vít Ondruch from comment #2)
> And how is the Rawhide signed then? Is the F25 key still in use? I'd say
> that some symlink would solve the issue for the moment.

It's not signed until a F-26 key is generated. Any of the fc25.rpm will be signed with f25 keys too. The problem will be resolved this week.

Comment 4 Dennis Gilmore 2016-08-08 12:17:34 UTC
f26 keys have been made, but there is no guarantees that rawhide is signed and you really should not rely on it being so. we sign it on a best effort basis, we have gpgcheck=0 for a reason in the repo files

Comment 5 Peter Robinson 2016-08-08 21:58:35 UTC
*** Bug 1365147 has been marked as a duplicate of this bug. ***