Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364095

Summary: [RFE] Containers should have "My filters" and advanced search same way as other providers
Product: Red Hat CloudForms Management Engine Reporter: Matouš Mojžíš <mmojzis>
Component: UI - OPSAssignee: zakiva
Status: CLOSED CURRENTRELEASE QA Contact: Dafna Ron <dron>
Severity: medium Docs Contact:
Priority: high    
Version: 5.6.0CC: bazulay, cpelland, dajohnso, fsimonce, hkataria, jhardy, mmojzis, mpovolny, obarenbo, simaishi, zakiva
Target Milestone: GAKeywords: FutureFeature, TestOnly, ZStream
Target Release: 5.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ui:container:filter:search
Fixed In Version: 5.8.0.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1395304 1395305 (view as bug list) Environment:
Last Closed: 2017-06-12 17:16:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1395304, 1395305    

Description Matouš Mojžíš 2016-08-04 13:07:30 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.6.1.0

How reproducible:
Always

Steps to Reproduce:
1.Go to Compute -> Containers -> Containers
2.
3.

Actual results:
There is only one global filter.

Expected results:
Quick search, advanced search and My Filters should be implemented on this page.

Additional info:

Comment 2 zakiva 2016-10-31 15:06:01 UTC
Opened PR to add advanced search to Containers explorer:
https://github.com/ManageIQ/manageiq/pull/12303

Regarding "My filters", I'm not sure what is the expected behavior. Do we want here some specific filters or something else?

Comment 4 zakiva 2016-11-13 08:49:29 UTC
I think it can be moved to POST, Federico can you confirm?

Comment 5 Federico Simoncelli 2016-11-14 16:20:08 UTC
(In reply to zakiva from comment #4)
> I think it can be moved to POST, Federico can you confirm?

Yes.
In the future feel free to check with Ari or someone else in the team (no need to wait for me).

Comment 8 Federico Simoncelli 2016-11-30 10:16:24 UTC
*** Bug 1381623 has been marked as a duplicate of this bug. ***

Comment 9 Dafna Ron 2017-02-10 13:27:47 UTC
there is an advanced search and I was able to create a filter and save it. 
verified on cfme pod with cfme-5.8.0.0-1.el7cf.x86_64