Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1364

Summary: There are some of problems with ppp-related scripts in initscripts-3.78
Product: [Retired] Red Hat Linux Reporter: eh
Component: initscriptsAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-02 22:32:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description eh 1999-02-27 19:12:42 UTC
1) script "/etc/sysconfig/network-scripts/ifup-ppp" cleans
out the file "var/run/ppp-$DEVICE.dev" and then runs pppd,
supposing that it will write something to that file. And the
script "/etc/sysconfig/network-scripts/ifdown-ppp" on the
line "file=/var/run/`cat /var/run/ppp-$DEVICE.dev`.pid"
supposes that there is the device name (e.g. "ppp0"). The
problem is that pppd (version 2.3.3 and 2.3.5) doesn't write
there anything, so ifdown can't find the PID and kill pppd.

2) when shutting down a ppp device by ifdown (no matter it
doesn't work), ifdown executes ifdown-ppp and then
ifdown-post. But ifdown-post is execute by ifdown-ppp and
even  by /etc/ppp/ip-down when pppd is killed. I think it
should only be executed by ifdown.

Comment 1 eh 1999-02-27 19:50:59 UTC
Oops! I just downloaded the official package and found out that the
package I used before was a bit modified (the file "/etc/ppp/ip-up"
was missing). So the first bug is fixed in the current release of me
:)
But the second one still seems to be there - the if*-post scripts are
still called several times (from /etc/ppp/ip-*,
/etc/sysconfig/network-scripts/if[up|down] and ifdown-ppp.

Comment 2 David Lawrence 1999-03-02 22:32:59 UTC
Unable to replicate this problem with the latest initscripst for 5.2.