Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1362069

Summary: [GSS] Rebalance crashed
Product: [Community] GlusterFS Reporter: Susant Kumar Palai <spalai>
Component: distributeAssignee: Susant Kumar Palai <spalai>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 3.8.1CC: amukherj, bugs, nbalacha, olim, rhs-bugs, spalai, storage-qa-internal
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glusterfs-3.8.2 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1359711 Environment:
Last Closed: 2016-08-12 09:48:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1352805, 1359711    
Bug Blocks:    

Comment 1 Vijay Bellur 2016-08-01 09:34:47 UTC
REVIEW: http://review.gluster.org/15061 (dht/rebalance: allocate migrator thread pool dynamically) posted (#1) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 2 Vijay Bellur 2016-08-04 06:54:52 UTC
REVIEW: http://review.gluster.org/15061 (dht/rebalance: allocate migrator thread pool dynamically) posted (#2) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 3 Vijay Bellur 2016-08-05 09:18:08 UTC
REVIEW: http://review.gluster.org/15061 (dht/rebalance: allocate migrator thread pool dynamically) posted (#3) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 4 Vijay Bellur 2016-08-09 15:08:48 UTC
REVIEW: http://review.gluster.org/15061 (dht/rebalance: allocate migrator thread pool dynamically) posted (#4) for review on release-3.8 by Susant Palai (spalai@redhat.com)

Comment 5 Vijay Bellur 2016-08-10 10:21:58 UTC
COMMIT: http://review.gluster.org/15061 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 7b17f93685d080676089302ef005b8c182335adf
Author: Susant Palai <spalai@redhat.com>
Date:   Thu Aug 4 12:23:40 2016 +0530

    dht/rebalance: allocate migrator thread pool dynamically
    
    Problems: The maximum number of migratior threads created was static set
    to "40". And the number of these threads get created in rebalance depends
    on the number of cores user has. If the number of cores exceeds 40, a
    crash or memory corruption can be seen.
    
    Fix: Make the migratior thread pool dynamic.
    
    > Change-Id: Ifbdac8a1a396363dd75e2f6bcb454070cfdbf839
    > BUG: 1362069
    > Reviewed-on: http://review.gluster.org/15000
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    (cherry picked from commit b8e8bfc7e4d3eaf76bb637221bc6392ec10ca54b)
    
    Change-Id: Ifbdac8a1a396363dd75e2f6bcb454070cfdbf839
    BUG: 1362069
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/15061
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 6 Niels de Vos 2016-08-12 09:48:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/