Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1361903

Summary: There are two shotwell icons on the desktop.
Product: [Fedora] Fedora Reporter: Ervin <ervindiner>
Component: shotwellAssignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 24CC: mclasen, michel, sid, thomas.moschny, willmyalex
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: shotwell-0.23.5-1.fc24 shotwell-0.23.5-1.fc23 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-25 13:54:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Two "shotwells" on the desktop none

Description Ervin 2016-07-31 17:19:20 UTC
Created attachment 1186154 [details]
Two "shotwells" on the desktop

Description of problem:
A recent update of shotwell brought two shotwell desktop icons on the desktop. 

Version-Release number of selected component (if applicable):
0.23.4

How reproducible:
Always

Steps to Reproduce: (not sure what exact steps to follow) 
1.Upgrade shotwell to 0.23.4 if you were using an older version. 
2.
3.

Actual results:
There are two shotwell icons on the desktop. 

Expected results:
There should be only one as it is normal for apps. 

Additional info:
Both "shotwells" are the same program.

Comment 1 Alex Willmy 2016-08-02 18:42:55 UTC
I have the same problem. There seems to be a bug in one of the .desktop files.
/usr/share/applications/shotwell-viewer.desktop is missing the 'NoDisplay=true' entry which was present in earlier versions.

Comment 2 Alex Willmy 2016-08-02 20:15:09 UTC
This issue has been fixed upstream;

https://git.gnome.org/browse/shotwell/commit/?id=255a39c9e5c9df94bc16f2988ac50f9bc6dd9866

Comment 3 Fedora Update System 2016-08-18 14:51:27 UTC
shotwell-0.23.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d520993a98

Comment 4 Fedora Update System 2016-08-18 14:51:43 UTC
shotwell-0.23.5-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c464dca50d

Comment 5 Fedora Update System 2016-08-19 00:23:13 UTC
shotwell-0.23.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d520993a98

Comment 6 Fedora Update System 2016-08-19 00:58:54 UTC
shotwell-0.23.5-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c464dca50d

Comment 7 Fedora Update System 2016-08-25 13:54:07 UTC
shotwell-0.23.5-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-08-27 20:50:52 UTC
shotwell-0.23.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.