Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1361635

Summary: Backport allocation-ratio-to-resource-tracker to OSP 7.
Product: Red Hat OpenStack Reporter: Pablo Caruana <pcaruana>
Component: openstack-novaAssignee: Eoghan Glynn <eglynn>
Status: CLOSED CANTFIX QA Contact: Prasanth Anbalagan <panbalag>
Severity: high Docs Contact:
Priority: unspecified    
Version: 7.0 (Kilo)CC: berrange, dansmith, dcadzow, ealcaniz, eglynn, felipe.alfaro, kchamart, rbryant, sbauza, sferdjao, sgordon, srevivo, vromanso
Target Milestone: ---Keywords: FeatureBackport, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-05 14:54:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Pablo Caruana 2016-07-29 15:15:26 UTC
    
 What is the nature and description of the request?  

When applying resource overcommits to Compute nodes, it's very hard to figure out whether they are working or not. resource overcommit ratios are applied when scheduling instances, and not when Hypervisors (e.g. compute nodes) report their resources back to the controllers.

On OSP 7 as it is right now, oversubscription is completely opaque. Since neither the hypervisors nor the Nova service itself take into account, except for scheduling, it's impossible to know whether a particular Nova instance will schedule or not when 100% of the real resources are used.

Comment 4 Dan Smith 2016-08-05 14:37:02 UTC
The referenced patch is only a very tiny bit of the overall feature and is not a functional change on its own. The larger work around moving where the ratios are reported and honored is large. It involves RPC and DB schema changes, as well as some constraints on how the upgrade across the boundary is handled. Thus, this is not a candidate for a feature backport, IMHO.

Comment 6 Stephen Gordon 2016-08-05 14:55:56 UTC
(In reply to Dan Smith from comment #4)
> The referenced patch is only a very tiny bit of the overall feature and is
> not a functional change on its own. The larger work around moving where the
> ratios are reported and honored is large. It involves RPC and DB schema
> changes, as well as some constraints on how the upgrade across the boundary
> is handled. Thus, this is not a candidate for a feature backport, IMHO.

As this is not backportable to the RHOSP 7 code base in a safe manner I am marking CLOSED CANTFIX.

Comment 7 awaugama 2017-09-07 19:14:32 UTC
Closed without a fix therefore QE won't automate