Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1361310

Summary: Service retirement does not work from service details page
Product: Red Hat CloudForms Management Engine Reporter: Jeff Warnica <jwarnica>
Component: UI - OPSAssignee: Harpreet Kataria <hkataria>
Status: CLOSED DUPLICATE QA Contact: Niyaz Akhtar Ansari <nansari>
Severity: medium Docs Contact:
Priority: high    
Version: 5.6.0CC: cpelland, dajohnso, hkataria, jhardy, jwarnica, mpovolny, nansari, obarenbo
Target Milestone: GAKeywords: ZStream
Target Release: 5.7.0Flags: hkataria: needinfo? (jwarnica)
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: service:retirement
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1361690 (view as bug list) Environment:
Last Closed: 2016-08-05 17:06:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1361690    

Description Jeff Warnica 2016-07-28 18:30:13 UTC
Description of problem:

Service retirement does not work from service details page


How reproducible:
always

Steps to Reproduce:
1. Navigate to a service from /service/explorer in the classic UI
2. Lifecycle->Retire

Actual results:
"No services were selected for retire" displayed


Expected results:
Retirement begins

Additional info:
Retirement does seem to happen if one ore multiple services are selected from the list, and Lifecycle->Retire is triggered.

Comment 3 Jeff Warnica 2016-08-03 14:42:21 UTC
The same problem happens with instance retirement. I guess this is the same layout and code so it makes sense it also fails.

Comment 4 Harpreet Kataria 2016-08-04 16:31:26 UTC
Jeff,

Can you provide build information and if possible can i access your appliance to try and recreate the issue. This is not recreatable on upstream locally.

Thanks,
~Harpreet

Comment 5 Harpreet Kataria 2016-08-05 17:06:19 UTC
This issue has already been fixed with fix for 
https://bugzilla.redhat.com/show_bug.cgi?id=1344678
https://bugzilla.redhat.com/show_bug.cgi?id=1349989

Thanks,
~Harpreet

*** This bug has been marked as a duplicate of bug 1344678 ***