Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1361251

Summary: totem has just green picture, cirrus/vnc VM setup broken
Product: Red Hat Enterprise Linux 7 Reporter: Matěj Cepl <mcepl>
Component: clutterAssignee: Owen Taylor <otaylor>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact: Lucie Maňásková <lmanasko>
Priority: unspecified    
Version: 7.3CC: bnocera, jkoten, otaylor, rduda, rmatos, tpelka, vbenes, vhumpa
Target Milestone: betaKeywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: clutter-1.20.0-10.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-04 01:45:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1362179    
Attachments:
Description Flags
stdout/stderr of the above command
none
output of dmesg
none
output of journalctl -xb none

Description Matěj Cepl 2016-07-28 15:30:37 UTC
Created attachment 1185161 [details]
stdout/stderr of the above command

Description of problem:
When playing any video (including Sintel, so don't blame it on non-free-codecs) with totem I get just green picture in the window and nothing else (I mean the place where the movie should show up is green, decoration of the window, buttons, etc. are OK). Sound is OK. The strange thing is that the same movie, on the same machine, with same gstreamer\* packages plays just fine with gst-launch playbin, or gst123, or gst-play-1.0.

Hadess blamed clutter, so I am filing the problem here, but it can go anywhere else as well.

Version-Release number of selected component (if applicable):
totem-nautilus-3.14.3-6.el7.x86_64
totem-pl-parser-devel-3.10.5-1.el7.x86_64
clutter-1.20.0-9.el7.x86_64
gstreamer1-plugins-bad-free-1.4.5-4.el7.x86_64
gstreamer-plugins-good-0.10.31-11.el7.x86_64
gstreamer1-plugins-base-tools-1.4.5-2.el7.x86_64
gstreamer-devel-0.10.36-7.el7.x86_64
gstreamer-plugins-bad-0.10.23-5.el7.nux.x86_64
gstreamer-plugins-base-0.10.36-10.el7.x86_64
gstreamer-tools-0.10.36-7.el7.x86_64
clutter-gtk-devel-1.4.4-7.el7.x86_64
clutter-gtk-debuginfo-1.4.4-7.el7.x86_64
gstreamer1-devel-1.4.5-1.el7.x86_64
gstreamer-plugins-bad-nonfree-0.10.23-2.el7.nux.x86_64
gstreamer1-debuginfo-1.4.5-1.el7.x86_64
gstreamer1-plugins-bad-freeworld-1.0.6-1.el7.nux.x86_64
gstreamer1-plugins-base-debuginfo-1.4.5-2.el7.x86_64
gstreamer-ffmpeg-0.10.13-15.el7.nux.x86_64
gstreamer-plugins-base-devel-0.10.36-10.el7.x86_64
gstreamer1-plugins-ugly-1.0.6-2.el7.nux.x86_64
totem-debuginfo-3.14.3-6.el7.x86_64
gstreamer-plugin-crystalhd-3.10.0-11.el7.x86_64
gstreamer-plugins-base-tools-0.10.36-10.el7.x86_64
gstreamermm-0.10.11-5.el7.x86_64
gstreamer1-plugins-base-1.4.5-2.el7.x86_64
gstreamer1-vaapi-0.6.1-1.el7.x86_64
gst123-0.3.3-4.el7.x86_64
totem-pl-parser-debuginfo-3.10.5-1.el7.x86_64
gstreamer1-plugins-good-1.4.5-2.el7.x86_64
gstreamer-0.10.36-7.el7.x86_64
gstreamer1-1.4.5-1.el7.x86_64
gstreamer1-libav-1.0.6-1.el7.nux.x86_64
gstreamer-plugins-bad-free-0.10.23-20.el7.x86_64
clutter-debuginfo-1.20.0-9.el7.x86_64
totem-3.14.3-6.el7.x86_64
gstreamer-plugins-ugly-0.10.19-17.el7.nux.x86_64
clutter-gst2-2.0.12-2.el7.x86_64
clutter-gst2-debuginfo-2.0.12-2.el7.x86_64
clutter-gst2-devel-2.0.12-2.el7.x86_64
totem-pl-parser-3.10.5-1.el7.x86_64
clutter-devel-1.20.0-9.el7.x86_64
clutter-gtk-1.4.4-7.el7.x86_64
gstreamer-python-0.10.22-6.el7.x86_64
gstreamer1-plugins-base-devel-1.4.5-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. totem --gst-debug-level=9 ~/build/torrent/Jane\ Eyre\ \(2011\)/Jane.Eyre.2011.720p.BrRip.X264.YIFY.mp4
2.
3.

Actual results:
see above, the stdout/stderr of this command is attached

Expected results:
enjoyment of the fine movie (although, this one is too brief, I prefer the 2006 BBC version ;))

Comment 1 Matěj Cepl 2016-07-28 15:31:24 UTC
Created attachment 1185162 [details]
output of dmesg

Comment 2 Matěj Cepl 2016-07-28 15:31:51 UTC
Created attachment 1185163 [details]
output of journalctl -xb

Comment 3 Owen Taylor 2016-07-28 16:07:55 UTC
From further testing that Matěj did, upgrading cogl by itself doesn't reproduce this, but when you upgrade clutter, it causes the problem. That seems to me to imply that this is some sort of fall-out from the gl3 enablement.

(With the nvidia driver, I see a crash at totem startup not this - don't have time to investigate further at the moment.)

Comment 4 Bastien Nocera 2016-07-28 18:35:52 UTC
It might be that a clutter-gtk bump might fix this, but it might require more rebuilding, as its API/ABI is quite fluid.

Comment 5 Jiri Koten 2016-08-03 10:22:02 UTC
*** Bug 1362462 has been marked as a duplicate of this bug. ***

Comment 7 Rui Matos 2016-08-11 17:54:37 UTC
I'll push a new clutter version that goes back to defaulting to the classic gl driver and adds API that mutter calls to request the gl3 driver.

Comment 9 Matěj Cepl 2016-08-12 21:39:31 UTC
Yes, clutter-1.20.0-10.el7 fixes this issue for me, the video shown in totem is correct again. Thank you!

Comment 10 Vitezslav Humpa 2016-08-15 12:56:03 UTC
The update with (clutter-1.20.0-9.el7.x86_64, mutter-3.14.4-27.el7.x86_64) fails to render gnome-shell, causing crash on startup. Might not happen on all HW, though breaks the cirrus/vnc VM setup - error message suggests that clutter can't find any backend driver.

$ systemctl start gdm.service

... log:

Aug 15 14:19:04 localhost systemd: Starting GNOME Display Manager...
Aug 15 14:19:04 localhost systemd: Started GNOME Display Manager.
Aug 15 14:19:04 localhost systemd: Created slice user-42.slice.
Aug 15 14:19:04 localhost systemd: Starting user-42.slice.
Aug 15 14:19:04 localhost systemd: Started Session c1 of user gdm.
Aug 15 14:19:04 localhost systemd-logind: New session c1 of user gdm.
Aug 15 14:19:04 localhost systemd: Starting Session c1 of user gdm.
Aug 15 14:19:04 localhost gnome-session: gnome-session[12455]: WARNING: Error getting login monitor: -13
Aug 15 14:19:04 localhost gnome-session[12455]: WARNING: Error getting login monitor: -13
Aug 15 14:19:04 localhost gnome-session: Entering running state
Aug 15 14:19:04 localhost gnome-session: (gnome-shell:12502): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to initialize the Clutter backend: no available drivers found.
Aug 15 14:19:04 localhost gnome-session: (gnome-shell:12502): mutter-ERROR **: Unable to initialize Clutter.
Aug 15 14:19:04 localhost kernel: traps: gnome-shell[12502] trap int3 ip:7fd950a9e643 sp:7fffe9314460 error:0
Aug 15 14:19:04 localhost abrt-hook-ccpp: Process 12502 (gnome-shell) of user 42 killed by SIGTRAP - dumping core
Aug 15 14:19:04 localhost rtkit-daemon[652]: Successfully made thread 12511 of process 12511 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.

-> black screen on standard startup or oops screen with autologin

HW:
00:00.0 Host bridge [0600]: Intel Corporation 440FX - 82441FX PMC [Natoma] [8086:1237] (rev 02)
00:01.0 ISA bridge [0601]: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] [8086:7000]
00:01.1 IDE interface [0101]: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] [8086:7010]
00:01.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 03)
00:02.0 VGA compatible controller [0300]: Cirrus Logic GD 5446 [1013:00b8]
00:03.0 Ethernet controller [0200]: Red Hat, Inc Virtio network device [1af4:1000]
00:04.0 Audio device [0403]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller [8086:2668] (rev 01)
00:05.0 Communication controller [0780]: Red Hat, Inc Virtio console [1af4:1003]
00:06.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:06.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:06.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:06.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:07.0 SCSI storage controller [0100]: Red Hat, Inc Virtio block device [1af4:1001]
00:08.0 Unclassified device [00ff]: Red Hat, Inc Virtio memory balloon [1af4:1002]

This is the ABRT FAF report, so for backtrace and other information please look here:
http://faf.lab.eng.brq.redhat.com/faf/reports/1386/

Comment 11 Vitezslav Humpa 2016-08-15 12:57:47 UTC
Oh, sorry that's update to clutter-1.20.0-10.el7.x86_64 and mutter-3.14.4-28.el7.x86_64 of course. Shell works fine with previously stated versions.

Comment 12 Rui Matos 2016-08-16 11:03:00 UTC
Should be fixed with mutter-3.14.4-29.el7

Comment 14 Tomas Pelka 2016-08-16 14:21:09 UTC
*** Bug 1367475 has been marked as a duplicate of this bug. ***

Comment 15 Tomas Pelka 2016-08-25 17:10:36 UTC
This issue is now fixed within 

cogl-1.18.2-12.el7
clutter-1.20.0-10.el7
mutter-3.14.4-29.el7

Comment 17 errata-xmlrpc 2016-11-04 01:45:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html