Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1361114

Summary: Can't access foreman location parameters
Product: Red Hat Satellite 6 Reporter: Tomas Strachota <tstrachota>
Component: Organizations and LocationsAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.1.0CC: bbuckingham, bkearney, cwelton, dsulliva, jcallaha, jscalf, jthomas, mburns, mmccune, oprazak, rhos-maint, srevivo, sthirugn, tstrachota
Target Milestone: 6.1Keywords: Triaged, ZStream
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/11764/
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1221710 Environment:
Last Closed: 2016-09-27 09:03:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1221710    
Bug Blocks: 1256461    

Comment 1 Tomas Strachota 2016-07-28 11:17:23 UTC
Cloning for 6.1.z

Comment 3 jcallaha 2016-09-21 20:48:37 UTC
Verified in Satellite 6.1.10 Snap 1.1. 
You can now see the parameters for a location when using the parameters path. However, you cannot view the parameters when visiting the base path. As this issue does not stop us from viewing the parameters, I will not fail this bug, instead a new one will be filed.

GET https://rhsm-qe-1.rhq.lab.eng.bos.redhat.com/api/v2/locations/3/parameters/
{
  "total": 2,
  "subtotal": 2,
  "page": 1,
  "per_page": 20,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [
    {
      "id": 3,
      "name": "param1",
      "value": "first test parameter",
      "priority": null,
      "created_at": "2016-09-21T20:38:04Z",
      "updated_at": "2016-09-21T20:38:04Z"
    },
    {
      "id": 4,
      "name": "param2",
      "value": "second test parameter",
      "priority": null,
      "created_at": "2016-09-21T20:38:04Z",
      "updated_at": "2016-09-21T20:38:04Z"
    }
  ]
}



GET https://rhsm-qe-1.rhq.lab.eng.bos.redhat.com/api/v2/locations/3
{
  "id": 3,
  "name": "Brand New Location",
  "title": "Default Location/Brand New Location",
  "created_at": "2016-09-20T19:31:12Z",
  "updated_at": "2016-09-21T20:38:34Z",
  "select_all_types": [
    "ConfigTemplate",
    "Hostgroup"
  ],
  "description": "",
  "parameters": [
    {},
    {}
  ],
  "users": [],
  "smart_proxies": [],
  "subnets": [],
  "compute_resources": [],
  "media": [],
  "config_templates": [],
  "domains": [],
  "environments": [],
  "hostgroups": [],
  "organizations": []
}

Comment 5 errata-xmlrpc 2016-09-27 09:03:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938