Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1360592

Summary: [Q35] win10 guest BSOD when boot up with 22 switches
Product: Red Hat Enterprise Linux 7 Reporter: jingzhao <jinzhao>
Component: qemu-kvm-rhevAssignee: Vadim Rozenfeld <vrozenfe>
Status: CLOSED WONTFIX QA Contact: jingzhao <jinzhao>
Severity: low Docs Contact:
Priority: low    
Version: 7.3CC: chayang, ghammer, jinzhao, juzhang, knoel, virt-maint, vrozenfe, yduan, yiwei
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-07 07:46:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jingzhao 2016-07-27 06:31:35 UTC
Description of problem:
win10 BSOD when boot up with 22 switches

Version-Release number of selected component (if applicable):
qemu-kvm-tools-rhev-2.6.0-15.el7.x86_64
kernel-3.10.0-478.el7.x86_64

How reproducible:
3/6

Steps to Reproduce:
1.Boot up win10 guest which contain 22 switches with following cli
sh switch-layer.sh 21
[root@intel-3323-24-1 home]# cat switch-layer.sh 
#!/bin/sh

MACHINE=q35
SMP=4,cores=2,threads=2,sockets=1
MEM=2G
GUEST_IMG=/home/q35.qcow2
IMG_FORMAT=qcow2

CLI="/usr/libexec/qemu-kvm -enable-kvm -M $MACHINE -cpu SandyBridge -smp $SMP -m $MEM -name vm1 -drive file=$GUEST_IMG,if=none,id=guest-img,format=$IMG_FORMAT,werror=stop,rerror=stop -device ide-hd,drive=guest-img,bus=ide.0,unit=0,id=os-disk,bootindex=0 -spice port=5931,disable-ticketing -vga qxl -monitor stdio -serial unix:/tmp/console,server,nowait -qmp tcp:0:6666,server,nowait -chardev file,path=/home/seabios.log,id=seabios -device isa-debugcon,chardev=seabios,iobase=0x402 -boot menu=on,reboot-timeout=8,strict=on -device ioh3420,bus=pcie.0,id=root.0,slot=3 -device x3130-upstream,bus=root.0,id=upstream -device xio3130-downstream,bus=upstream,id=downstream0,chassis=1"
while [ ${i:=0} -lt ${1:-0} ]
do
    dstreamId=$((i+1))
    ustreamId=$((i+1))
    chassisId=$((dstreamId+1))
    blkDiskId=$((i))


    CLI="$CLI -device x3130-upstream,bus=downstream$i,id=upstream$ustreamId"    
    CLI="$CLI -device xio3130-downstream,bus=upstream$ustreamId,id=downstream$dstreamId,chassis=$chassisId"
    i=$((i+1))
done
   CLI="$CLI -device virtio-scsi-pci,bus=downstream$dstreamId,id=scsi3,disable-legacy=on,disable-modern=off -drive file=/home/layerblock.qcow2,if=none,id=drive-virtio-disk6,format=qcow2,cache=none,werror=stop,rerror=stop -device scsi-hd,bus=scsi3.0,drive=drive-virtio-disk6,id=virtio-disk6"

$CLI

2. shut down win10 guest through "system_powerdown" or you can do some opeartion in win10 guest (such as copy or check the file )

Actual results:
win10 guest BSOD

Expected results:
Win10 guest shut down correctly or win10 run normally

Additional info:

Comment 1 jingzhao 2016-07-27 06:52:36 UTC
The kernel memory dump file, please check http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/

Thanks
Jing Zhao

Comment 3 Gal Hammer 2016-07-27 11:44:07 UTC
(In reply to jingzhao from comment #1)
> The kernel memory dump file, please check
> http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/
> 
> Thanks
> Jing Zhao

Thanks for the dump file. Can you please upload it again after compression?

Comment 4 Gal Hammer 2016-07-27 11:49:05 UTC
In addition to comment #3. Did you installed the netkvm driver? or one of the virtio-win drivers? If yes, then which version? Thanks.

Comment 5 jingzhao 2016-07-28 01:24:32 UTC
(In reply to Gal Hammer from comment #4)
> In addition to comment #3. Did you installed the netkvm driver? or one of
> the virtio-win drivers? If yes, then which version? Thanks.

Hi

  Updated the dump file again, you can check it through http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/kerneldump.tar.gz

I didn't install the netkvm driver because I didn't attach the net device.
I just attached virtio scsi device to the switch(such as root port -- switch --switch ....-switch --virtio scsi). I used the virtio1.0 driver which download from virtio-win-prewhql-0.1-122

Comment 6 Gal Hammer 2016-07-28 06:08:54 UTC
(In reply to jingzhao from comment #5)
> (In reply to Gal Hammer from comment #4)
> > In addition to comment #3. Did you installed the netkvm driver? or one of
> > the virtio-win drivers? If yes, then which version? Thanks.
> 
> Hi
> 
>   Updated the dump file again, you can check it through
> http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/
> kerneldump.tar.gz

There is a problem with the tar.gz file. The memory dump compressed well, but 129 bytes?
 
> I didn't install the netkvm driver because I didn't attach the net device.
> I just attached virtio scsi device to the switch(such as root port -- switch
> --switch ....-switch --virtio scsi). I used the virtio1.0 driver which
> download from virtio-win-prewhql-0.1-122

Does this bsod also occurs if using ide-drive without virtio scsi?

Comment 7 jingzhao 2016-07-28 08:48:47 UTC
(In reply to Gal Hammer from comment #6)
> (In reply to jingzhao from comment #5)
> > (In reply to Gal Hammer from comment #4)
> > > In addition to comment #3. Did you installed the netkvm driver? or one of
> > > the virtio-win drivers? If yes, then which version? Thanks.
> > 
> > Hi
> > 
> >   Updated the dump file again, you can check it through
> > http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/
> > kerneldump.tar.gz
> 
> There is a problem with the tar.gz file. The memory dump compressed well,
> but 129 bytes?
---Updated the dump file, please re-check it on the website
>  
> > I didn't install the netkvm driver because I didn't attach the net device.
> > I just attached virtio scsi device to the switch(such as root port -- switch
> > --switch ....-switch --virtio scsi). I used the virtio1.0 driver which
> > download from virtio-win-prewhql-0.1-122
> 
> Does this bsod also occurs if using ide-drive without virtio scsi?
----Didn't hit the issue if using ide without virtio scsi (tried 4 times and didn't occurs)

Thanks
Jing Zhao

Comment 9 Vadim Rozenfeld 2016-07-28 12:36:07 UTC
Unfortunately http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/kerneldump.zip is almost useless. Could you please reproduce the problem when running read/write operations and upload the crashdump file?  I would also would like to see the output from "info pci" command issued  form qemu monitor.

Thanks,
Vadim.

Comment 10 jingzhao 2016-07-29 06:55:05 UTC
(In reply to Vadim Rozenfeld from comment #9)
> Unfortunately
> http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/bug1360592/
> kerneldump.zip is almost useless. Could you please reproduce the problem
> when running read/write operations and upload the crashdump file?  I would
> also would like to see the output from "info pci" command issued  form qemu
> monitor.
> 
> Thanks,
> Vadim.

Reproduce this issue when running iometer tools (2 times /5 times), but it's weird about that I didn't get the dump file, only got the mini dump file, hope can help you. please check the above website

And, follow is the info pci message:
(qemu) info pci
  Bus  0, device   0, function 0:
    Host bridge: PCI device 8086:29c0
      id ""
  Bus  0, device   1, function 0:
    VGA controller: PCI device 1b36:0100
      IRQ 10.
      BAR0: 32 bit memory at 0xf4000000 [0xf7ffffff].
      BAR1: 32 bit memory at 0xf8000000 [0xfbffffff].
      BAR2: 32 bit memory at 0xfc250000 [0xfc251fff].
      BAR3: I/O at 0xc040 [0xc05f].
      BAR6: 32 bit memory at 0xffffffffffffffff [0x0000fffe].
      id ""
  Bus  0, device   2, function 0:
    PCI bridge: PCI device 8086:3420
      BUS 0.
      secondary bus 1.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "root.0"
  Bus  1, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 1.
      secondary bus 2.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream"
  Bus  2, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 2.
      secondary bus 3.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream0"
  Bus  3, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 3.
      secondary bus 4.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream1"
  Bus  4, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 4.
      secondary bus 5.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream1"
  Bus  5, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 5.
      secondary bus 6.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream2"
  Bus  6, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 6.
      secondary bus 7.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream2"
  Bus  7, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 7.
      secondary bus 8.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream3"
  Bus  8, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 8.
      secondary bus 9.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream3"
  Bus  9, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 9.
      secondary bus 10.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream4"
  Bus 10, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 10.
      secondary bus 11.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream4"
  Bus 11, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 11.
      secondary bus 12.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream5"
  Bus 12, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 12.
      secondary bus 13.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream5"
  Bus 13, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 13.
      secondary bus 14.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream6"
  Bus 14, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 14.
      secondary bus 15.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream6"
  Bus 15, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 15.
      secondary bus 16.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream7"
  Bus 16, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 16.
      secondary bus 17.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream7"
  Bus 17, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 17.
      secondary bus 18.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream8"
  Bus 18, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 18.
      secondary bus 19.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream8"
  Bus 19, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 19.
      secondary bus 20.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream9"
  Bus 20, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 20.
      secondary bus 21.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream9"
  Bus 21, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 21.
      secondary bus 22.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream10"
  Bus 22, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 22.
      secondary bus 23.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream10"
  Bus 23, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 23.
      secondary bus 24.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream11"
  Bus 24, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 24.
      secondary bus 25.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream11"
  Bus 25, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 25.
      secondary bus 26.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream12"
  Bus 26, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 26.
      secondary bus 27.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream12"
  Bus 27, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 27.
      secondary bus 28.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream13"
  Bus 28, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 28.
      secondary bus 29.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream13"
  Bus 29, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 29.
      secondary bus 30.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream14"
  Bus 30, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 30.
      secondary bus 31.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream14"
  Bus 31, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 31.
      secondary bus 32.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream15"
  Bus 32, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 32.
      secondary bus 33.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream15"
  Bus 33, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 33.
      secondary bus 34.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream16"
  Bus 34, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 34.
      secondary bus 35.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream16"
  Bus 35, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 35.
      secondary bus 36.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream17"
  Bus 36, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 36.
      secondary bus 37.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream17"
  Bus 37, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 37.
      secondary bus 38.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream18"
  Bus 38, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 38.
      secondary bus 39.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream18"
  Bus 39, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 39.
      secondary bus 40.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream19"
  Bus 40, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 40.
      secondary bus 41.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream19"
  Bus 41, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 41.
      secondary bus 42.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream20"
  Bus 42, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 42.
      secondary bus 43.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream20"
  Bus 43, device   0, function 0:
    PCI bridge: PCI device 104c:8232
      BUS 43.
      secondary bus 44.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "upstream21"
  Bus 44, device   0, function 0:
    PCI bridge: PCI device 104c:8233
      BUS 44.
      secondary bus 45.
      subordinate bus 45.
      IO range [0xf000, 0x0fff]
      memory range [0xfc000000, 0xfc1fffff]
      prefetchable memory range [0xfe000000, 0xfe7fffff]
      id "downstream21"
  Bus 45, device   0, function 0:
    SCSI controller: PCI device 1af4:1048
      IRQ 0.
      BAR1: 32 bit memory at 0xfc000000 [0xfc000fff].
      BAR4: 64 bit prefetchable memory at 0xfe000000 [0xfe7fffff].
      id "scsi3"
  Bus  0, device   3, function 0:
    Ethernet controller: PCI device 1af4:1000
      IRQ 0.
      BAR0: I/O at 0xc060 [0xc07f].
      BAR1: 32 bit memory at 0xfc252000 [0xfc252fff].
      BAR4: 64 bit prefetchable memory at 0xfd800000 [0xfdffffff].
      BAR6: 32 bit memory at 0xffffffffffffffff [0x0003fffe].
      id ""
  Bus  0, device  31, function 0:
    ISA bridge: PCI device 8086:2918
      id ""
  Bus  0, device  31, function 2:
    SATA controller: PCI device 8086:2922
      IRQ 0.
      BAR4: I/O at 0xc080 [0xc09f].
      BAR5: 32 bit memory at 0xfc253000 [0xfc253fff].
      id ""
  Bus  0, device  31, function 3:
    SMBus: PCI device 8086:2930
      IRQ 10.
      BAR4: I/O at 0x0700 [0x073f].
      id ""
(qemu) 

Additional -- following is the steps which I set the kernel dump file
1. Right-click My Computer, and then click Properties.
2. Click the Advanced tab.
3. Under Startup and Recovery, click Settings.
4. Make sure that Kernel memory dump or Complete memory dump is selected under Writing Debugging Information.
5. You can change the location of the memory dump file to a different local partition if you do not have sufficient room on the partition where the operating system is installed. 
6. In Registry Editor, locate the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
7. Right-click CrashControl, point to New, and then click DWORD Value.
8. Type NMICrashDump, and then press ENTER.
9. Right-click NMICrashDump, and then click Modify.
10. In the Value data box, type 1, and then click OK.
11. Restart the computer.


Thanks
Jing Zhao