Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1360332

Summary: Scheduled reports are emailing ever few seconds rather then just 1
Product: Red Hat CloudForms Management Engine Reporter: John Prause <jprause>
Component: ReportingAssignee: Joe Rafaniello <jrafanie>
Status: CLOSED WONTFIX QA Contact: Dave Johnson <dajohnso>
Severity: high Docs Contact:
Priority: unspecified    
Version: 5.5.0CC: cpelland, jhardy, jrafanie, obarenbo
Target Milestone: GAKeywords: ZStream
Target Release: 5.5.6   
Hardware: x86_64   
OS: Linux   
Whiteboard: report
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1354629 Environment:
Last Closed: 2018-12-11 15:24:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1354629    
Bug Blocks:    

Comment 3 CFME Bot 2016-07-28 22:00:43 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/85c117362f898d357d7a02377e9f82f4a17f3a61

commit 85c117362f898d357d7a02377e9f82f4a17f3a61
Author:     d-m-u <duhlmann@redhat.com>
AuthorDate: Thu Jul 28 17:29:19 2016 -0400
Commit:     d-m-u <duhlmann@redhat.com>
CommitDate: Thu Jul 28 17:29:19 2016 -0400

    Avoid issue with Rufus caching time within options
    
    Rufus scheduler 3.0.8+ started modifying the input options hash at
    jmettraux/rufus-scheduler@c074a59
    
    This commit allows schedules to parse the time using Chronic.
    Unfortunately, for speed, they cache the result of the first parse in the
    input options hash, causing us to schedule the same time many times!
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1360332

 app/models/miq_schedule_worker/runner.rb       | 4 ++--
 spec/models/miq_schedule_worker/runner_spec.rb | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)

Comment 5 CFME Bot 2016-09-06 20:17:03 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4dfdf6a6ddf32aec3a172b7751d9b76805b5d8d9

commit 4dfdf6a6ddf32aec3a172b7751d9b76805b5d8d9
Merge: 62e9828 c5b0a24
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Tue Sep 6 16:13:31 2016 -0400
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Tue Sep 6 16:13:31 2016 -0400

    Merge branch 'backport_rufus_308_fix' into '5.5.z'
    
    Avoid issue with Rufus caching time within options
    
    This is NOT currently a blocker for 5.5.z.  Do not MERGE if we're blockers only.
    
    Backport of https://github.com/ManageIQ/manageiq/pull/10129, since 5.5.z allows rufus-scheduler ~> 3.1.x.
    There was a conflict cherry-picking the test from this commit.
    
    
    Rufus scheduler 3.0.8+ started modifying the input options hash at
    jmettraux/rufus-scheduler@c074a59
    
    This commit allows schedules to parse the time using Chronic.
    Unfortunately, for speed, they cache the result of the first parse in the
    input options hash, causing us to schedule the same time many times!
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1360332
    
    See merge request !1028

 app/models/miq_schedule_worker/runner.rb       | 4 ++--
 spec/models/miq_schedule_worker/runner_spec.rb | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)

Comment 6 CFME Bot 2016-09-06 20:17:08 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c5b0a2449d081c756c53a7752f80d5dd449ad4f9

commit c5b0a2449d081c756c53a7752f80d5dd449ad4f9
Author:     d-m-u <duhlmann@redhat.com>
AuthorDate: Thu Jul 28 17:29:19 2016 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Fri Aug 12 14:24:22 2016 -0400

    Avoid issue with Rufus caching time within options
    
    Rufus scheduler 3.0.8+ started modifying the input options hash at
    jmettraux/rufus-scheduler@c074a59
    
    This commit allows schedules to parse the time using Chronic.
    Unfortunately, for speed, they cache the result of the first parse in the
    input options hash, causing us to schedule the same time many times!
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1360332

 app/models/miq_schedule_worker/runner.rb       | 4 ++--
 spec/models/miq_schedule_worker/runner_spec.rb | 3 +++
 2 files changed, 5 insertions(+), 2 deletions(-)