Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1359757

Summary: Lifecycle Environment Paths page does not disable 'New Environmet Path' button while 'GET paths' request is in progress
Product: Red Hat Satellite 6 Reporter: Roman Plevka <rplevka>
Component: WebUIAssignee: satellite6-bugs <satellite6-bugs>
WebUI sub component: Katello QA Contact: Katello QA List <katello-qa-list>
Status: CLOSED UPSTREAM Docs Contact:
Severity: unspecified    
Priority: unspecified CC: bbuckingham, walden
Version: 6.2.0Keywords: Triaged
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-20 00:11:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Roman Plevka 2016-07-25 12:09:01 UTC
Description of problem:
If user loads LCE page, [s]he's is immediately presented by a 'Library' path with enabled 'New Environment Path' button. However, 'New environment path' form relies on 'GET paths' request to be completed in order to evaluate 'prior_id' of the environment.
If user clicks the button before 'GET paths' ajax request is finished, the prior_id will be: '' and the form will fail to save any attempt to create new Environment Path.

Version-Release number of selected component (if applicable):
satellite-6.2.0-21.1.el6sat.noarch (RCM build)

How reproducible:
always

Steps to Reproduce:
1. navigate to Life Cycle Environments page (possibly open up browser debugger to capture the HTTP requests)
2. while 'GET paths' request is in progress, click 'New Environment Path' button
3. on the 'New Environment" dialog, you should see 'Adding Lifecycle Environment to the end of "" '. <- note that the prior LCE is not being evaluated.
4. try to create new environment -> "param is missing or the value is empty: prior_id"

Actual results:
"param is missing or the value is empty: prior_id"

Expected results:
The button won't be enabled until all needed requests are completed.

Additional info:

Comment 2 Walden Raines 2016-12-20 00:11:27 UTC
This seems to have since been fixed upstream.  Now I do not see the add new environment button until the environment path is loaded.  Please reopen if you see this not working as expected upstream.