Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1358667

Summary: Undocumented grub options
Product: Red Hat Enterprise Linux 7 Reporter: Tereza Cerna <tcerna>
Component: rearAssignee: Jakub Mazanek <jmazanek>
Status: CLOSED NOTABUG QA Contact: Tereza Cerna <tcerna>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: mhlavink
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-18 09:17:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tereza Cerna 2016-07-21 08:46:11 UTC
Description of problem:
Grub options GRUB_RESCUE and GRUB_RESCUE_PASSWORD are not documented in manual page. 

Rear version:
rear-1.17.2

Link to github issue:
https://github.com/rear/rear/issues/935

Comment 3 Jakub Mazanek 2017-08-18 09:17:06 UTC
Options are not documented in manual pages, but since rear-1.19 the usage is well explained in the comments in /usr/share/rear/conf/default.conf. As I understand it, it is by design as this feature is considered corner case by the upstream developers