Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1358482

Summary: pypy-libs missing _gdbm_cffi.pypy-26.so
Product: [Fedora] Fedora Reporter: Frank Zdarsky <fzdarsky>
Component: pypyAssignee: Miro Hrončok <mhroncok>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: mcyprian, mhroncok, python-sig, tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: pypy-5.0.1-4.fc25 pypy-5.0.1-4.fc24 pypy-4.0.1-4.fc23 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-28 23:51:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Frank Zdarsky 2016-07-20 19:51:58 UTC
Description of problem:
pypy-libs package doesn't contain the pre-built _gdbm_cffi.pypy-26.so, leading to "no module named _gdbm_cffi" errors in python project relying on that module. See http://pypy.org/download.html, section "Packaging".

Version-Release number of selected component (if applicable):
pypy-libs.x86_64                          4.0.1-3.fc23

How reproducible:
always

Steps to Reproduce:
1. Under F23, dnf install pypy
2. try to run a python script relying on module _gdbm_cffi with pypy
  e.g. git checkout https://github.com/openstack/tripleo-validations and run tox

Actual results:
Execution fails with "No module named _gdbm_cffi".

Expected results:
Execution succeeds.

Additional info:
Running
  cd /usr/lib64/pypy-4.0.1/lib_pypy/ && sudo pypy _gdbm_build.py
builds the missing shared library.

Comment 1 Miro Hrončok 2016-07-21 09:15:31 UTC
It's explicitly disabled in the spec, don't know why.

http://pkgs.fedoraproject.org/cgit/rpms/pypy.git/tree/pypy.spec#n457

I was able to build pypy33 with gdbm here: http://copr.fedoraproject.org/coprs/churchyard/pypy33 https://github.com/fedora-python/pypy3/blob/pypy33/pypy3.spec#L205

I'll look into this.

Comment 2 Miro Hrončok 2016-07-22 10:06:49 UTC
Building in rawhide (scratch build before built fine) http://koji.fedoraproject.org/koji/taskinfo?taskID=14978806

Comment 3 Miro Hrončok 2016-07-26 12:09:44 UTC
I can do import _gdbm_cffi in rawhide. Will backport the fix.

Comment 5 Fedora Update System 2016-07-26 23:37:58 UTC
pypy-5.0.1-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9c3b982335

Comment 6 Fedora Update System 2016-07-26 23:38:27 UTC
pypy-4.0.1-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c647d3ab59

Comment 7 Frank Zdarsky 2016-07-27 12:37:55 UTC
Works for me and addresses the above issue. Thanks a lot!

Comment 8 Miro Hrončok 2016-07-27 17:52:31 UTC
In that case, please, add positive karma to the updates.

Comment 9 Frank Zdarsky 2016-07-27 19:49:15 UTC
[x] done

Comment 10 Fedora Update System 2016-07-28 04:17:57 UTC
pypy-4.0.1-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c647d3ab59

Comment 11 Fedora Update System 2016-07-28 05:59:08 UTC
pypy-5.0.1-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9c3b982335

Comment 12 Fedora Update System 2016-07-28 23:51:08 UTC
pypy-5.0.1-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-07-29 02:50:32 UTC
pypy-4.0.1-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.