Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1358224

Summary: Calamari api /api/v2/cluster/<fsid>/sync_object/config returns blank values for public_network and cluster_network
Product: Red Hat Ceph Storage Reporter: Shubhendu Tripathi <shtripat>
Component: CalamariAssignee: Gregory Meno <gmeno>
Calamari sub component: Back-end QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Status: CLOSED NOTABUG Docs Contact:
Severity: unspecified    
Priority: unspecified CC: ceph-eng-bugs, hnallurv
Version: 2.0   
Target Milestone: rc   
Target Release: 2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-20 15:11:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Shubhendu Tripathi 2016-07-20 09:56:54 UTC
Description of problem:
The Calamari api /api/v2/cluster/<fsid>/sync_object/config returns blank values for public_network and cluster_network.

Version-Release number of selected component (if applicable):
1.4.7-1

How reproducible:
100%

Steps to Reproduce:
1. Create a ceph cluster with say 3 mon and 1 osd node
2. Access the calamari api /api/v2/cluster/<fsid>/sync_object/config
3.

Actual results:
Blank values for public_network and cluster_network

Expected results:
Should provide correct values for public_network and cluster_network

Additional info:
Due to this issue, import cluster flow in USM is affected and network details for imported cluster nodes are not populated properly.

Comment 2 Gregory Meno 2016-07-20 15:11:24 UTC
You should really be using the /mon endpoint for this.

Calamari is not altering this structure at all. It reports exactly what ceph does.

Looking at http://docs.ceph.com/docs/jewel/rados/troubleshooting/troubleshooting-mon/

Gives a way to check this value from ceph itself

(env) root@gray-bunting:~/calamari/calamari-common# ceph --admin-daemon $(ceph-conf --name mon.$(hostname) --show-config-value admin_socket) config get cluster_network
{
    "cluster_network": ""
}

With calamari not in the picture I'd say this is a change in the config values -- not a bug.

If cluster network is set in the [global] section in /etc/ceph/<cluster_name>.conf then it will be present otherwise it will be absent.