Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1357539

Summary: Missing information about RSYNC using in man page
Product: Red Hat Enterprise Linux 7 Reporter: Tereza Cerna <tcerna>
Component: rearAssignee: Jakub Mazanek <jmazanek>
Status: CLOSED CURRENTRELEASE QA Contact: qe-baseos-daemons
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2   
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-08-16 13:23:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tereza Cerna 2016-07-18 13:15:37 UTC
Description of problem:
   In manual page is written that BACKUP_URL should be specified when using 
   BACKUP=NETFS, not BACKUP=RSYNC. But it is required if only BACKUP=RSYNC 
   is used.

   Copy&paste from man page:
      When using BACKUP=NETFS you should provide the backup target location
      through the BACKUP_URL variable. Possible BACKUP_URL settings are:

   Current output:
      # rear -v mkbackup
      Relax-and-Recover 1.17.2 / Git
      Using log file: /var/log/rear/rear-rearclient.log
      ERROR: Missing BACKUP_URL=rsync://[USER@]HOST[:PORT][::]/PATH !
      Aborting due to an error, check /var/log/rear/rear-rearclient.log 
      for details
      Terminated

   Expected output:
      Change in man page.

Rear version:
   rear-1.17.2

Link to github issue:
   https://github.com/rear/rear/issues/930

Comment 4 Jakub Mazanek 2017-08-16 13:23:56 UTC
This is fixed in rear-2.00 man page